0

Yet another Tomcat install error

asked 2006-04-02 03:29:11 +0800

admin gravatar image admin
18691 1 10 129
ZK Team


Orignial message at:
https://sourceforge.net/forum/message.php?msg_id=3664135

By: eburkitt

When I attempt to install ZKDemo.war, Tomcat (4.1) logs the following error:
Exception sending context initialized event to listener instance of class com.potix.web.init.LabelLocatorHook
java.lang.ExceptionInInitializerError
Caused by: java.security.AccessControlException: access denied (java.util.PropertyPermission com.potix.comp.ComponentManager.class read). The referenced class is in in pxcommon.jar and that file, along with all the other .jar files from zk-1.1.0.tar.gz, are in $TOMCAT_HOME/shared/lib. Could this be a Java configuration problem?

delete flag offensive retag edit

3 Replies

Sort by ยป oldest newest

answered 2006-04-03 02:27:08 +0800

admin gravatar image admin
18691 1 10 129
ZK Team


Orignial message at:
https://sourceforge.net/forum/message.php?msg_id=3665080

By: tomyeh

Looks like you turned on java policy (java.security.manager and java.security.policy).

If so, you have to modify catalina.policy and add the following permission to ZK's libraries.

permission java.util.PropertyPermission "*", "read";
permission java.util.PropertyPermission "com.potix.*", "read, write";
permission java.util.logging.LoggingPermission "control";
permission java.io.FilePermission "C:\\usr\\Tomcat5.5\\conf\\-", "read";
permission java.io.FilePermission "C:\\usr\\Tomcat5.5\\shared\\-", "read";
permission java.io.FilePermission "C:\\usr\\Tomcat5.5\\webapps\\-", "read";
permission java.io.FilePermission "C:\\usr\\Tomcat5.5\\temp\\-", "read, write, delete";
permission java.lang.RuntimePermission "accessClassInPackage.org.apache.catalina.loader";


link publish delete flag offensive edit

answered 2006-04-04 14:31:27 +0800

admin gravatar image admin
18691 1 10 129
ZK Team


Orignial message at:
https://sourceforge.net/forum/message.php?msg_id=3668526

By: henrichen

Did your problem solved?

/henri

link publish delete flag offensive edit

answered 2006-04-06 00:59:19 +0800

admin gravatar image admin
18691 1 10 129
ZK Team


Orignial message at:
https://sourceforge.net/forum/message.php?msg_id=3671797

By: michaelkmb

Also, check whether Tomcat 4.1 support servlet spec 2.4 (which is a requirement for ZK).

According to Tomcat 4 documentation, it does not.


"Tomcat 4 implements the Servlet 2.3 and JavaServer Pages 1.2 specifications from Java Software, ... "

Regards,
Michael

link publish delete flag offensive edit
Your reply
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow

RSS

Stats

Asked: 2006-04-02 03:29:11 +0800

Seen: 905 times

Last updated: Apr 06 '06

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More