0

installing zkdemo on tomcat 5.5

asked 2006-04-14 20:34:01 +0800

admin gravatar image admin
18691 1 10 129
ZK Team


Orignial message at:
https://sourceforge.net/forum/message.php?msg_id=3687413

By: gladiator

The following exception is encountered, I am sure all the jar files including zk.jar are under Tomcat 5.5\shared\lib. I am not sure why it complains com.potix.zk.ui.http.HttpSessionListener
class not found. Rebooted the pc.
any idea?

org.apache.catalina.core.StandardContext listenerStart
SEVERE: Error configuring application listener of class com.potix.zk.ui.http.HttpSessionListener
java.lang.ClassNotFoundException: com.potix.zk.ui.http.HttpSessionListener
at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.jav
a:1352)
at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.jav
a:1198)
at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:
3677)
at org.apache.catalina.core.StandardContext.start(StandardContext.java:4183)
at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1013)
at org.apache.catalina.core.StandardHost.start(StandardHost.java:718)
at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1013)
at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:442)
at org.apache.catalina.core.StandardService.start(StandardService.java:450)
at org.apache.catalina.core.StandardServer.start(StandardServer.java:709)
at org.apache.catalina.startup.Catalina.start(Catalina.java:551)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39
)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl
.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)
at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:275)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)
Apr 14, 2006 1:28:25 PM org.apache.catalina.core.StandardContext listenerStart
SEVERE: Skipped installing application listeners due to previous error(s)

delete flag offensive retag edit

1 Reply

Sort by ยป oldest newest

answered 2006-04-14 20:57:23 +0800

admin gravatar image admin
18691 1 10 129
ZK Team


Orignial message at:
https://sourceforge.net/forum/message.php?msg_id=3687572

By: gladiator

Ok this has to do with eclipse's dev environment. seems like copying all the jars into tomcat/shared/lib is not enough, I needed to copy the jars into WEB-INF/lib as well. I only need to do this if I use eclipse to deploy to tomcat 5.5.

link publish delete flag offensive edit
Your reply
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow

RSS

Stats

Asked: 2006-04-14 20:34:01 +0800

Seen: 782 times

Last updated: Apr 14 '06

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More