zkau response problem behind proxy cache

asked 2015-08-04 09:50:57 +0800

aktejo gravatar image aktejo
155 3

Dear experts,

I encounter a problem accessing zkoss page from my office computer. The problem is that Any zkoss page doesn't react on any action I have no control on network setup, including proxy and cache setting, but I presume the it is because of the proxy or cache settings.

The problem is, no matter which is the ajax post from client, server always return the same response.

I observe the ajax-net using firebug, and found out this information.

Zkoss page: zkoss demo grid data binding, Url as follow:


From the firebug I can see the following zkau url to invoke:


When I navigate through the grid item, the browser post different (post) information to the server. Please observe the ""items" uuid

post #1

{"items":["zA2Qn1"],"reference":"zA2Qn1","clearFirst":false,"selectAll":false,"pageX":591,"pageY":391 ,"which":1,"x":87,"y":104}

Howeever, the response is remain the same for different au post. (on select event)

response #1

{"rs":[["setAttr",[{$u:'zA2Qv'},"value","Balu Haben"]],["setAttr",[{$u:'zA2Qe0'},"value","Balu"]],["setAttr" ,[{$u:'zA2Qf0'},"value","Haben"]],["setAttr",[{$u:'zA2Qh0'},"value","Balu Haben"]]],"rid":1}

post #2

{"items":["zA2Qr1"],"reference":"zA2Qr1","clearFirst":false,"selectAll":false,"pageX":629,"pageY":429 ,"which":1,"x":125,"y":142}

response #2:

{"rs":[["setAttr",[{$u:'zA2Qv'},"value","Balu Haben"]],["setAttr",[{$u:'zA2Qe0'},"value","Balu"]],["setAttr" ,[{$u:'zA2Qf0'},"value","Haben"]],["setAttr",[{$u:'zA2Qh0'},"value","Balu Haben"]]],"rid":1}

post #3

{"items":["zA2Q22"],"reference":"zA2Q22","clearFirst":false,"selectAll":false,"pageX":709,"pageY":525 ,"which":1,"x":205,"y":238}

response #3

{"rs":[["setAttr",[{$u:'zA2Qv'},"value","Balu Haben"]],["setAttr",[{$u:'zA2Qe0'},"value","Balu"]],["setAttr" ,[{$u:'zA2Qf0'},"value","Haben"]],["setAttr",[{$u:'zA2Qh0'},"value","Balu Haben"]]],"rid":1}

Is this a known issue? how to resolve? Thanks in advance

delete flag offensive retag edit


We did not encounter this problem so far. Does it only happen on a specific computer/browser (version?) or for all computers in your office? In addition can you please post the dtid parameter for each request, this should remain the same for subsequent ajax requests.

cor3000 ( 2015-08-05 00:16:07 +0800 )edit

Thanks for the response, What is dtid and where can I found it?

It happened for all browser installed in the station, IE, FF, Chrome. It also happened in different stations of my colleagues. It didn't happen in my Laptop, since the laptop is connected to different network segment using WIFI.

aktejo ( 2015-08-21 14:26:44 +0800 )edit

the dtid is the desktop ID, you can find it in any zkau/ request from the client to the server. it is used to identify which browser tab (or (i)frame) is sending the request to enable multiple tabs per user session. you can see it e.g. in the chrome network tab:

cor3000 ( 2015-08-24 01:56:49 +0800 )edit

the first parameter of the request is the dtid, then events: dtid:z_1t cmd0:onAnchorPos uuid0:rEsPj data0:{"top":96,"left":0} cmd1:onSelect uuid1:rEsPj data_1:{"items":["rEsPv1"],"reference":"rEsPv1","clearFirst":false,"selectAll":false,"pageX":762,"pageY":448,"which":1,"x":138,"y":161}

cor3000 ( 2015-08-24 01:57:23 +0800 )edit

if these parameters have no effect on the server response, it's likely a proxy is caching an zkau response that shouldn't be cached. also the fact that your wifi doesn't have the problem indicates the same. requests for different dtid's should result in different zkau responses.

cor3000 ( 2015-08-24 02:01:41 +0800 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2017-02-08 08:04:11 +0800

aktejo gravatar image aktejo
155 3

Till now the problem persists. However, I've got a new information. I run same code, using maven jetty (mvn clean jetty:run), in different cloud servers. It works. the problem disappear.

I was just wondered, if this problem occurred because I run it in DigitalOcean, In digital ocean I use NGINX to proxy_pass the jetty. I tried to turn the NGINX off, but the problem still around. so its not because of the NGINX I suppose.

any clue?

link publish delete flag offensive edit

answered 2018-09-12 05:07:16 +0800

naarani gravatar image naarani

I've it only with nginx on DigitalOcean

link publish delete flag offensive edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools




Asked: 2015-08-04 09:50:57 +0800

Seen: 36 times

Last updated: Sep 12 '18

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More