0

Upgrade to ZK 9.0.0 - "Package Settings" missing

asked 2020-02-03 22:35:47 +0800

assonaZkDev004 gravatar image assonaZkDev004
101

updated 2020-02-04 22:36:15 +0800

Hi,

I would like to upgrade from ZK 8.0.5 to ZK 9.0.0. I already downloaded the version and added the archived file in Eclipse (Window -> Preferences -> ZK -> ZK Packages).

However, I cannot find the entry "ZK -> Package Settings" in the Properties menu of my project to re-associate the source jar files.

Does anybody know, what is wrong here?

I'm using Eclipse version 2019-12 (4.14.0)

delete flag offensive retag edit

4 Answers

Sort by ยป oldest newest most voted
0

answered 2020-02-05 10:52:40 +0800

cor3000 gravatar image cor3000
5099 2 7
ZK Team

I am using Version: 2019-03 (4.11.0) where it still works:

I added the package via Window -> Preferences -> ZK -> ZK Packages

image description

Then the version appears in the drop down:

Project Properties -> ZK -> Package Settings -> select from the drop down as in the screenshot below:

image description

Is this option missing in your case?

I'll increase your karma so you can provide screen shots.

link publish delete flag offensive edit
0

answered 2020-02-05 21:02:48 +0800

assonaZkDev004 gravatar image assonaZkDev004
101

Hi, thanks for increasing my karma :-) and your kind help.

I also added the package via Window -> Preferences -> ZK -> ZK Packages:

image description

But there is no drop down entry "Package Setting":

image description

It's a Maven project - could that be the point?

link publish delete flag offensive edit
0

answered 2020-02-06 11:30:19 +0800

cor3000 gravatar image cor3000
5099 2 7
ZK Team

updated 2020-02-07 11:46:38 +0800

Yes Maven is the key. I was about to suggest maven anyway, so this zkstudio feature doesn't apply to your project. In most cases only legacy projects of the 'pre-maven/gradle-era' need to manage dependencies manually. And that's where the ZK Studio plugin can help automating part of this otherwise tedious/manual approach - using the package settings option. It's not available for projects managed via maven.

So in your case it's safe to remove the zk 9.0.0 package again from zk studio (or keep it, it won't hurt/do anything lying around). Instead change the zk version in your pom.xml and eclipse's maven plugin will update the dependencies.

If something gets stuck it often helps to update the project: (Right click the project to open the context menu -> Maven -> Update Project OR Download javadocs/sources).

link publish delete flag offensive edit
0

answered 2020-02-06 15:34:14 +0800

assonaZkDev004 gravatar image assonaZkDev004
101

So the mystery has been solved :)

Thank you very much for your kind and fast help!

link publish delete flag offensive edit

Comments

you're welcome

cor3000 ( 2020-02-07 13:44:55 +0800 )edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
1 follower

RSS

Stats

Asked: 2020-02-03 22:35:47 +0800

Seen: 18 times

Last updated: Feb 07

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More