0

Maven2 http no longer used

asked 2020-01-16 18:33:26 +0800

hechteka gravatar image hechteka
51 1

updated 2020-01-17 09:24:40 +0800

cor3000 gravatar image cor3000
5099 2 7
ZK Team

Please help. I'm getting the following error when compiling my project in Netbeans .. please note this code compiled fine yesterday I see on some sites the http should no longer be used but when I do that I need a certificate.

Failed to transfer file: http://repo.maven.apache.org/maven2/org/zkoss/zk/zkbind/7.0.3.2/zkbind-7.0.3.2.pom. Return code is: 501, ReasonPhrase: HTTPS Required.

Pom.xml

....
      <repositories>
        <repository>
            <id>ZK CE</id>
            <name>ZK CE Repository</name>
            <url>http://mavensync.zkoss.org/maven2</url>            
        </repository> 
        <repository>
            <id>ZK EE</id>
            <url>https://maven.zkoss.org/repo/zk/ee</url>
          </repository>
    </repositories>
....

Changing zkce url from http to https:

Could not transfer artifact org.ngi:zhighcharts:pom:0.2.0 from/to ZK CE (https://mavensync.zkoss.org/maven2): sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

delete flag offensive retag edit

Comments

See the origin of this issue and why I can no longer build my project https ://stackoverflow.com/questions/59763531/maven-dependencies-are-failing-with-501-error/59769360#59769360

hechteka ( 2020-01-16 20:09:05 +0800 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2020-01-17 10:12:58 +0800

cor3000 gravatar image cor3000
5099 2 7
ZK Team

updated 2020-01-17 10:16:28 +0800

you didn't mention it but it sounds like your java version doesn't support the Let's encrypt certificate used on our repo https://mavensync.zkoss.org/maven2

If that's the case you have to either import the certificate manually or upgrade to a supported java version as mentioned in this list (recommended)

from https://letsencrypt.org/docs/certificate-compatibility/

  • Java 7 >= 7u111
  • Java 8 >= 8u101

This does not mean you have to run your project using this Java version, just the maven process needs to run using a version supporting the SSL certificate when downloading the dependencies into your local .m2/repository folder.

If this doesn't help, please contact our support directly.

link publish delete flag offensive edit

Comments

Thanks cor3000 yes that helps definitely. When I chose a higher version (3.5.2) of Maven than my bundled 3.0.5 version on Netbeans 8.2 it built my project without the http/s changes. Hopefully that solves it but so far all looks good. Much appreciated.

hechteka ( 2020-01-17 15:27:21 +0800 )edit

good to know, you're welcome

cor3000 ( 2020-01-17 16:23:41 +0800 )edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
2 followers

RSS

Stats

Asked: 2020-01-16 18:33:26 +0800

Seen: 6 times

Last updated: Jan 17

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More