0

ZK Charts 2.1 now released!

asked 2015-10-21 07:47:25 +0800

tendysu gravatar image tendysu
1731 1 2

updated 2015-10-21 07:57:08 +0800

ZK Charts has now been upgraded to version 2.1, bringing new features like box plot, tree map and polygon series!

ZK Charts 2.1 New Features

ZK Charts 2.1 Release Note

delete flag offensive retag edit

4 Replies

Sort by ยป oldest newest

answered 2015-10-27 13:31:32 +0800

IngoB gravatar image IngoB flag of Germany
256 6

updated 2015-10-27 14:18:03 +0800

Hi,

I got another issue. I want to set the "ThousandsSep" to "," (comma) like it was before (at least for us). The chart is not displaying it!

Options options = new Options();
options.getLang().setThousandsSep(",");
charts.setOptions(options);

I tried setting it to "~" like you suggested, which is working. Even "." (dot) is working. I found a fiddle, so Highcharts is capable of displaying a comma -> http://jsfiddle.net/eeDnv/456/

-edit-

options.getLang().setDecimalPoint(",");

is working, so "comma" is not a problem.

-edit2-

options.getLang().setThousandsSep("<span>,</span>");

is working as a workaround.

Is this a bug or is it not possible to display a comma as a separator for thousands?

link publish delete flag offensive edit

answered 2015-10-23 08:52:09 +0800

IngoB gravatar image IngoB flag of Germany
256 6

Thank you for your clarification. You are right, it's the first one which is added. My problem remains the same, since it's not about the tooltip. I want to hide the series you see (the "last" drawn).

link publish delete flag offensive edit

answered 2015-10-23 04:54:47 +0800

christopherszu gravatar image christopherszu
1501

Both changes are from Highcharts.

ZK Charts 2.1 uses Highcharts 4.1.5, and the default thousands separator has been changed to " " (a single space) since 4.1.0, see highcharts doc, but that can be changed by setting the global option
Options options = new Options();
options.getLang().setThousandsSep("~");
chart.setOptions(options);

ZK Charts 2.0.1 uses Highcharts 4.0.4, the tooltip behavior is exactly the way you described, always showing the last drawn, like 4.0.4 sample, but in Highcharts 4.1.5, they are now showing the first drawn (didn't notice the random behavior), like 4.1.5 sample, if you would like to see the tooltip for overlapping points, you can use the shared option in tooltip, like shared sample, or chart.getTooltip().setShared(true); in ZK Charts.

link publish delete flag offensive edit

answered 2015-10-22 13:45:15 +0800

IngoB gravatar image IngoB flag of Germany
256 6

updated 2015-10-22 13:47:04 +0800

Hi,

I noticed some different behavior (from version 2.0.1).

Are these bugs or intended behavior (haven't read anything in the release notes)?

link publish delete flag offensive edit
Your reply
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
1 follower

RSS

Stats

Asked: 2015-10-21 07:47:25 +0800

Seen: 70 times

Last updated: Oct 27 '15

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More