0

Create zk theme 8.0.1

asked 2016-03-10 03:11:02 +0800

longdv1208 gravatar image longdv1208
98 4

I read the instructions for creating more here zk http://blog.zkoss.org/2013/09/17/zk7-create-a-new-a-theme-project/ But I do not find zk-archetype-theme on the link http://mavensync.zkoss.org/maven2/ 8.0.1 (http://mavensync.zkoss.org/maven2/archetype-catalog.xml). so as the create themes in eclipse error

delete flag offensive retag edit

3 Answers

Sort by ยป oldest newest most voted
1

answered 2016-03-10 07:23:13 +0800

Darksu gravatar image Darksu
1991 1 4

Hello longdv1208,

I Found the following entry in the catalog:

<archetype>
<groupId>org.zkoss</groupId>
<artifactId>zk-archetype-theme</artifactId>
<version>8.0.0.4</version>
<description>
An archetype that generates a starter ZK theme project
</description>
</archetype>

Can you post the error that is produced?

Best Regards,

Darksu

link publish delete flag offensive edit

Comments

I'm using 8.0.1 zk. I wanted to create a theme zk 8.0.1 ? . Thank

longdv1208 ( 2016-03-11 03:58:50 +0800 )edit
1

answered 2016-03-11 06:36:47 +0800

Darksu gravatar image Darksu
1991 1 4

Hello longdv1208,

Please check the links below:

http://mvnrepository.com/artifact/org.zkoss/zk-archetype-theme

http://mvnrepository.com/artifact/org.zkoss/zk-archetype-theme/8.0.0.1

So could you please send the error messages that are been produced?

Best Regards,

Darksu

link publish delete flag offensive edit
0

answered 2016-03-14 04:04:16 +0800

longdv1208 gravatar image longdv1208
98 4

updated 2016-03-14 04:05:22 +0800

I create themes zk zk-archetype-theme with 8.0.0.4 complete.
But when the build error.

[WARNING] Error injecting: org.apache.maven.plugin.javadoc.JavadocReport java.lang.NoClassDefFoundError: org/codehaus/plexus/components/io/fileselectors/FileSelector at java.lang.Class.getDeclaredConstructors0(Native Method) at java.lang.Class.privateGetDeclaredConstructors(Class.java:2585) at java.lang.Class.getDeclaredConstructors(Class.java:1906)

thank.

link publish delete flag offensive edit

Comments

this sounds more like a maven problem, can you share your pom.xml with the relevant information?

cor3000 ( 2016-03-14 06:21:35 +0800 )edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
2 followers

RSS

Stats

Asked: 2016-03-10 03:11:02 +0800

Seen: 27 times

Last updated: Mar 14 '16

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More