Revision history [back]

click to hide/show revision 1
initial version

asked 2014-10-01 13:07:07 +0800

abcd123 gravatar image abcd123

ZKOSS 5.0.14

Hello,

when using <include> component in defer mode ( <include mode="defer"/> ) zkoss malforms json sent from the server to zkoss client ( triggered by a click on one of the buttons on the page with include component ), by inserting extra commas:

[ "addChd", [ "zMBPj2", , [ 'zhtml.Widget', 'zMBPha', { prolog:'

    ', epilog:'
' }, [ ] ] ] ]

This results in SyntaxError on the client.

If the mode attribute is not set - i.e. it defaults to the other mode, the problem dissapears.

Is this a known issue? Can somebody advice how to get rid of the problem?

Regards.

ZKOSS 5.0.145.0.14 - bug in json producer?

Hello,

when using <include> component in defer mode ( <include mode="defer"/> ) zkoss malforms json sent from the server to zkoss client ( triggered by a click on one of the buttons on the page with include component ), by inserting extra commas:

[ "addChd", [ "zMBPj2", , [ 'zhtml.Widget', 'zMBPha', { prolog:'

    ', epilog:'
' }, [ ] ] ] ]

This results in SyntaxError on the client.

If the mode attribute is not set - i.e. it defaults to the other mode, the problem dissapears.

Is this a known issue? Can somebody advice how to get rid of the problem?

Regards.

ZKOSS 5.0.14 - bug in json producer?

Hello,

when using <include> component in defer mode ( <include mode="defer"/> ) zkoss malforms json sent from the server to zkoss client ( triggered by a click on one of the buttons on the page with include component ), by inserting extra commas:

 [
         "addChd",
         [
            "zMBPj2",
"zMBPj2", ,
            [
               'zhtml.Widget',
               'zMBPha',
               {
                  prolog:'

    ', epilog:'
'
prolog:'<ul id="zMBPha">', epilog:'</ul>' }, [ ] ] ] ] ]

This results in SyntaxError on the client.

If the mode attribute is not set - i.e. it defaults to the other mode, the problem dissapears.

Is this a known issue? Can somebody advice how to get rid of the problem?

Regards.

ZKOSS 5.0.14 - bug in json producer?

Hello,

when using <include> component in defer mode ( <include mode="defer"/> ) zkoss malforms json sent from the server to zkoss client ( triggered by a click on one of the buttons on the page with include component ), by inserting extra commas:

 [
         "addChd",
         [
            "zMBPj2", "zMBPj2",
 ,
            [
               'zhtml.Widget',
               'zMBPha',
               {
                  prolog:'<ul id="zMBPha">',
                  epilog:'</ul>'
               },
               [ ]
            ]
         ]   
 ]

This results in SyntaxError on the client.

If the mode attribute is not set - i.e. it defaults to the other mode, the problem dissapears.

Is this a known issue? Can somebody advice how to get rid of the problem?

Regards.

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More