Revision history [back]

click to hide/show revision 1
initial version

asked 2013-01-22 10:14:47 +0800

cvarona gravatar image cvarona

coerceFromString_ override no longer works from 6.5.1

Hi,

there seems to be some problem with widget functions overriding starting from zk 6.5.1. This used to work in zk 6.5.0:

zk.$import('zul.inp.Doublebox', function(cls) {
        zul.inp.Doublebox.prototype.coerceFromString_ = function(value) {
                blabla
                ...
            }
} );

However, after upgrading to 6.5.1 and 6.5.1.1 it doesn't (my custom coerceFromString_ function does not get invoked any longer).

Has anybody experienced this problem? Should I open a bug report?

With kind regards

César Varona

coerceFromString_ override no longer works from 6.5.1

Hi,

there seems to be some problem with widget functions overriding starting from zk 6.5.1. This used to work in zk 6.5.0:

zk.$import('zul.inp.Doublebox', function(cls) {
        zul.inp.Doublebox.prototype.coerceFromString_ = function(value) {
                blabla
                ...
            }
} );

However, after upgrading to 6.5.1 and 6.5.1.1 it doesn't (my custom coerceFromString_ function does not get invoked any longer).

Has anybody experienced this problem? Should I open a bug report?

With kind regards

César Varona

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More