0

Override z-index on modal window

asked 2015-07-17 01:36:42 +0800

yagamipaul gravatar image yagamipaul
15 2

Hi,

I'm using a window as a modal dialog with Executions.createComponent. My main page uses a html template based on bootstrap. With a current update of the template, they put some high values of z-index in some components, as a result, when I show up the modal, other components are on top of it.

I tried to put the style attribute on the window, changing the z-index value, but ZK always creates the window component with a z-index of 1800, no matter what i do.

How can I control that?, changing the z-index values of my template is not an option, i should be able to change the ones of my modal window.

I'm using ZK 7.0.3 CE.

Thanks!.

delete flag offensive retag edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-07-17 07:10:06 +0800

chillworld gravatar image chillworld flag of Belgium
5357 4 9
https://github.com/chillw...

Hey,

Can you try this out :

<style>
    .z-modal-mask{
        z-index:2000!important;
    }
</style>

Greetz Chill.

link publish delete flag offensive edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
1 follower

RSS

Stats

Asked: 2015-07-17 01:36:42 +0800

Seen: 33 times

Last updated: Jul 17 '15

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More