Random session timeout

asked 2014-12-23 10:56:20 +0800

deepp1990 gravatar image deepp1990
1 1

updated 2014-12-23 10:56:59 +0800

In our system, we have encountered a problem where the timeout occurs randomly. It does not depend on what I am doing in my system, the system times out. That is, server side session is running but at client side, the message appears where it is written as - "Your session has expired." and it is redirected to the login page. Session timeout has been configured in web.xml as 30 minutes. Many times it displays this alert after just 5 seconds of login. There is no code in the system that explicitly fires logout.

For reference, configuration in zk.xml is mentioned below.

<session-config> <device-type>ajax</device-type> <session-timeout>0</session-timeout> <max-desktops-per-session>15</max-desktops-per-session> <max-requests-per-session>5</max-requests-per-session> <automatic-timeout>true</automatic-timeout> <timeout-uri>/Login.zul?r=1</timeout-uri> <timer-keep-alive>true</timer-keep-alive> </session-config>

delete flag offensive retag edit

2 Answers

Sort by ยป oldest newest most voted

answered 2014-12-27 17:05:21 +0800

Darksu gravatar image Darksu
1991 1 4

Hello deepp1990,

Based on the provided configuration i made some tests using tomcat 7 and the session works as expected.

At the following url it dictates that the Default 0 (is dependant on the Web server).


Thus could you please post the configuration you are using?

Also why dont you set the session timeout only in the zk.xml?

Best Regards,


link publish delete flag offensive edit

answered 2014-12-29 09:21:04 +0800

deepp1990 gravatar image deepp1990
1 1

updated 2014-12-29 09:21:49 +0800

Hi Darksu,

We are using Weblogic for application server. I will surely try setting the session timeout in zk.xml. Will get back to you with the status.

The configuration in ZK.XML





    <description>ThreadLocal Synchronization Listener</description>

    <value> org.springframework.security.context.ThreadLocalSecurityContextHolderStrategy=contextHolder;

Thank You..

link publish delete flag offensive edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

1 follower



Asked: 2014-12-23 10:56:20 +0800

Seen: 19 times

Last updated: Dec 29 '14

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More