Problem deploy tomcat (Help me)

asked 2014-12-04 15:18:22 +0800

wigberto gravatar image wigberto
52 4

updated 2014-12-05 12:48:04 +0800

Help me, please!!!

I have an application that when I deploy in 'jetty server' running, but when I deploy on tomcat not find me the paths of .zul pages.


  • When I deploy to jetty, the url that appears is: http://localhost:8080/index.zul
  • When I deploy to tomcat, the url that appears is: http://localhost:808/dimensiona/index.zul When I select an option from the sidebar in working jetty and tomcat not find the path. Page sidebar:

    <nav label="${labels.labels.maintenance}" iconsclass="z-icon-angle-double-right" sclass="grey"> <navitem label="${labels.activities.activities}" iconsclass="z-icon-list" href="/activities/page.zul"/> <navitem label="${labels.configParms.configParms}" iconsclass="z-icon-list" href="/configparms/page.zul"/> <navitem label="${labels.resources.resources}" iconsclass="z-icon-list" href="/resources/page.zul"/> </nav>

If I change href from 'href="/resources/page.zul"' to 'href="resources/page.zul"' when I select one navitem works fine on tomcat, but when I select another navitem not work because the wrong path appears.



I hope I explained well, sorry for the English, thanks

delete flag offensive retag edit

1 Answer

Sort by » oldest newest most voted

answered 2014-12-04 16:45:49 +0800

terrytornado gravatar image terrytornado flag of Germany
9393 3 7 16

updated 2014-12-04 16:46:12 +0800

Tomcat uses the war file name as default docBasePath. Seems Jetty not.

Have a try to test both cases in this way:


best Stephan

link publish delete flag offensive edit


Thanks Stephan thanks but no works, appears the error: Estado HTTP 404 - /~./activities/page.zul

type Informe de estado

mensaje /~./activities/page.zul

descripción El recurso requerido no está disponible.

Apache Tomcat/7.0.50

wigberto ( 2014-12-05 10:50:46 +0800 )edit

can you show us an image of the project structure where we can see the zul folders?

terrytornado ( 2014-12-06 21:20:53 +0800 )edit

I'm sorry, I can not upload a picture because I have no kharma > 100. I can send it differently (email, etc)? Thank you terrytornado.

wigberto ( 2014-12-09 11:05:44 +0800 )edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

1 follower



Asked: 2014-12-04 15:18:22 +0800

Seen: 28 times

Last updated: Dec 05 '14

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More