event.stopPropagation in MinimizeEvent not working in zk 7.0.1

asked 2014-10-07 07:48:53 +0800

sentinal gravatar image sentinal
11 2

updated 2014-10-09 10:36:46 +0800

This is my code

<window id="chatW" border="none" mode="overlapped"
    viewModel="@id('vm') @init('zul.chat.chattest.ChatController')"
    title="${labels.conversation }" apply="org.zkoss.bind.BindComposer"

and method minimize in Controller

public void minimize(
        @ContextParam(ContextType.TRIGGER_EVENT) MinimizeEvent event) {
    System.out.println("in minimize event" + event);

And when i click on minimize button window disapear. How i can stop this event?

delete flag offensive retag edit


do you mean ZK 7.0.1 ??

JerryChen ( 2014-10-08 01:57:20 +0800 )edit

yes. i mean 7.0.1

sentinal ( 2014-10-09 10:37:21 +0800 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2014-10-14 08:16:18 +0800

JerryChen gravatar image JerryChen
1596 3
ZK Team

I'm wondering why you need to do that. It is a default behavior so Making the minimizable of the windows's property as false is straightforward. if you really want to do that, just simply do like following.

link publish delete flag offensive edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

1 follower



Asked: 2014-10-07 07:48:53 +0800

Seen: 12 times

Last updated: Oct 14 '14

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More