0

Bug listbox or not. [closed]

asked 2014-09-04 08:50:51 +0800

chillworld gravatar image chillworld flag of Belgium
5337 4 9
https://github.com/chillw...

updated 2014-09-04 09:25:20 +0800

Hi all,

I came just across this strange effect : Returning a ListModelList to listbox with multiple selection and checkmark true, I get radiobuttons as checkmark and unable to select multiple selections.

If I return normal list => checkmark are checkboxes and multile selection is possible.

I see it turns in zk 6.5.7 and zk 7.x. (didn't test earlier cases).

Saw also on forum that some people had problems with radiobuttons so this could be related.

Fiddle for testing is here : http://zkfiddle.org/sample/36jaodh/1-bug-listbox

Greetz chill.

delete flag offensive retag edit

The question has been closed for the following reason "the question is answered, right answer was accepted" by chillworld
close date 2015-03-26 16:46:32

1 Answer

Sort by » oldest newest most voted
1

answered 2014-09-04 09:09:47 +0800

Alecs gravatar image Alecs
103 5

related with this bug report which was closed. Solution? setMultiple(true) before setting the model. They're mentioning about this solution even in the documentation here

link publish delete flag offensive edit

Comments

Indeed, I watch over it in the documentation. Still funny solution for something what should work....

chillworld ( 2014-09-04 09:26:52 +0800 )edit

Question tools

Follow
1 follower

RSS

Stats

Asked: 2014-09-04 08:50:51 +0800

Seen: 9 times

Last updated: Sep 04 '14

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More