0

Portallayout maximize

asked 2014-05-26 12:38:47 +0800

IngoB gravatar image IngoB flag of Germany
256 6

Hi,

I want set a fixed "maximized" height for a panel in a portallayout. If I maximize a panel it always takes complete height of the portallayout (maximizedMode="whole"). But I want it only to "expand" by 500px. How to i solve this?

I tried to set the height on the maximize Event, but this is not working, any idea?

thanks

delete flag offensive retag edit

Comments

Another strange? behavior: onMove&onMinimize is not working, but onMaximize is triggered on min/maximize (Panel).

IngoB ( 2014-05-26 13:05:33 +0800 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2014-05-27 09:54:12 +0800

RaymondChao gravatar image RaymondChao
386 1 4
ZK Team

Portallayout supports onPortalMove which could be used to handle panel's movement in it.

The Panel's onMove is enable when movable="true" floatable="true", onMaximize is triggered by maximize icon, and onMinimize is triggered by minimize icon as the link.

And it can be given a fixed "maximized" height for a panel in a portallayout by CSS like the sample, but it's not flexible if the panel's height change dynamic.

link publish delete flag offensive edit

Comments

Thank you, this is exactly I'm looking for :)

IngoB ( 2014-05-27 12:47:15 +0800 )edit
0

answered 2014-05-27 13:49:14 +0800

IngoB gravatar image IngoB flag of Germany
256 6

Ok, i got another problem.

http://zkfiddle.org/sample/dt3asj/2-fixed-maximized-height-panel

If i maximize one panel (AAA) and then adding a new panel via testButton, there is an error?

link publish delete flag offensive edit

Comments

http://www.zkoss.org/zkdemo/layout/business_portal here you can recreate it too. Just maximize and try to add a new widget.

IngoB ( 2014-05-27 15:29:18 +0800 )edit

I found it's a bug and created an issue here: http://tracker.zkoss.org/browse/ZK-2310. The issue contains a temporary workaround, if it still has problems, please let us know.

RaymondChao ( 2014-05-28 08:10:19 +0800 )edit

No Problem, working fine! Thank you very very much!

IngoB ( 2014-05-28 13:11:24 +0800 )edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
1 follower

RSS

Stats

Asked: 2014-05-26 12:38:47 +0800

Seen: 16 times

Last updated: May 27 '14

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More