1

Spring security logout keeps processing...

asked 2014-01-20 18:03:22 +0800

gyowanny gravatar image gyowanny
283 1 2 6

Hi,

I have integrated Spring security to my ZKoss application and I'm getting a strange situtation: When I perform the logout by calling the spring's logout action this way:

<toolbarbutton href="/j_spring_security_logout" src="/resources/img/system-log-out.png" tooltiptext="Exit application"/>

When the logout is performed it redirects to the login page fine. However if I close, say, the Google Chrome tab, open a new one and go to the application it keeps displaying the "Processing..." message forever. Then if I click on the address bar and press enter then it gets to the login page again.

I noticed this error in my javascript console when I get the "Processing..." message:

Uncaught Unknown stub g8DP4                                            zk.wpd:21

My current ZK version is: 6.5.4

and below is my Spring Security configuration file:

   <http auto-config="true">
        <!-- ZK AU reqeust -->
        <intercept-url pattern="/zkau/**" access="IS_AUTHENTICATED_ANONYMOUSLY" />
        <!-- the login page -->
        <intercept-url pattern="/login.zul" access="IS_AUTHENTICATED_ANONYMOUSLY" />
        <intercept-url pattern="/timeout.zul" access="IS_AUTHENTICATED_ANONYMOUSLY" />
        <intercept-url pattern="/resources/img/**" access="IS_AUTHENTICATED_ANONYMOUSLY" />

        <!-- secure pages -->
        <intercept-url pattern="/**" access="ROLE_USER,ROLE_ADMIN" />

        <form-login login-page="/login.zul" default-target-url="/index.zul"
            authentication-failure-url="/login.zul?login_error=1"
            login-processing-url="/j_spring_security_check"/>

        <logout logout-success-url="/login.zul" invalidate-session="true" />
    </http>

Any clues?

Thank you

Gyo

delete flag offensive retag edit

3 Answers

Sort by ยป oldest newest most voted
1

answered 2014-04-30 04:10:55 +0800

neillee gravatar image neillee flag of Taiwan
1692 1 5
https://plus.google.com/u...

This issue were resolved by replacing

<html:form action="j_spring_security_check" method="POST" xmlns:html="native">

with

<html:form action="j_spring_security_check" method="POST" xmlns:html="xhtml">

link publish delete flag offensive edit
0

answered 2014-04-23 21:41:18 +0800

gyowanny gravatar image gyowanny
283 1 2 6

Any help with my question would be appreciated!

I've seen another ZK users asking the same question at the Spring's forum but no one there was able to answer so it's clear for me that this is something up to Zkoss.

link publish delete flag offensive edit

Comments

I noticed that such behavior is more reproducible in Google Chrome. Safari is fine.

gyowanny ( 2014-04-24 20:44:26 +0800 )edit
0

answered 2014-04-28 10:43:55 +0800

neillee gravatar image neillee flag of Taiwan
1692 1 5
https://plus.google.com/u...

Hello Gyowanny,

I have tried your spring security configuration on our ZK Spring Security example, but could not reproduce the issue you described. You may also want to compare your config with our config example.

The problem might be related to http://tracker.zkoss.org/browse/ZK-2051 as it happened while tabs were closed and opened in Chrome. So the problem might be a consequence of rmDesktop not fired properly. Please try the latest ZK 6.5.6 FL to see if the problem has already been resolved.

link publish delete flag offensive edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
2 followers

RSS

Stats

Asked: 2014-01-20 18:03:22 +0800

Seen: 46 times

Last updated: Apr 30 '14

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More