2

why open attribute doesn't work as desired.

asked 2013-07-02 08:25:22 +0800

nsharma gravatar image nsharma flag of India
917 1 11

updated 2013-07-02 08:31:30 +0800

<tree model="@load(vm.testmodel)" droppable="true" width="100%"
        vflex="1" hflex="1">
        <template name="model" var="node">
            <treeitem open="@load(node.open)">
                <treerow>
                    <treecell label="@load(node.data.name)"
                         />
                </treerow>
            </treeitem>
        </template>
    </tree>

Now if you use open="@load(node.open)"in treeitem,it works fine,but instead if you try to use open="true" ,this doesn't work.

Probably this has to do something with the model,but still making a attribute "true" should work fine. I have taken tree as an example,this works same for any other component,ex: Listgroup in listbox. can someone put some light on this.`

delete flag offensive retag edit

Comments

I am facing same Issue for Listgroup in listbox.

iamsudhir4u ( 2013-07-02 13:02:55 +0800 )edit
Be the first one to answer this question!
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
1 follower

RSS

Stats

Asked: 2013-07-02 08:25:22 +0800

Seen: 12 times

Last updated: Jul 02 '13

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More