NoSuchMethodError with Radio.getValue [closed]

asked 2013-05-23 11:19:28 +0800

M4tt gravatar image M4tt
39 5

updated 2013-05-23 11:23:40 +0800

I got an annoying error from Radio. Here is an example:


<radiogroup id="rg">
<radio value="0" label="true" selected="true"/>
<radio value="1" label="false"/>


(String) ((Radio) event.getTarget()).getValue()

It will throw a NoSuchMethodError every time when it invokes getValue().

SEVERE: >>java.lang.NoSuchMethodError: org.zkoss.zul.Radio.getValue()Ljava/lang/String;

I did clean and rebuild the .war file, then re-deploy. It didn't work. I deleted all the cache files in tomcat and deleted anything in webapps,then re-deployed my web project. It didn't work.

It happens only on the linux OS for now, I can't reproduce this error on my Windows. It happens both on CentOS 5.5 and Fedora 7 with tomcat 7 and tomcat 6. And I tried to build it with zkee 6.5.1 and 6.5.2, got the same error.

Please help, thank you!

delete flag offensive retag edit

The question has been closed for the following reason "the question is answered, right answer was accepted" by benbai
close date 2013-06-27 10:28:11


Can you attached war file some othersite so that i can test in my Linux OS

sjoshi ( 2013-05-23 13:22:46 +0800 )edit

Sadly, I failed to reproduce this error with a simple web project... I have no clue what to do, maybe I'll try downgrade to 6.5 or earlier.

M4tt ( 2013-05-24 08:50:31 +0800 )edit

After I downgraded to 6.0.2 the error has gone. I tried 6.5.2,6.5.1,6.5 before that. I know that I provided too little information about this, so ... Thanks anyway.

M4tt ( 2013-05-24 09:11:21 +0800 )edit

Question tools

1 follower



Asked: 2013-05-23 11:19:28 +0800

Seen: 10 times

Last updated: May 23 '13

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More