0

jasperreport not found in [LanguageDefinition: xul/html]

asked 2013-04-13 19:13:21 +0800

Antoc gravatar image Antoc
21 4

I have created a zul page (named main.zul) which uses a jasperreport component. I am currently using zk 6.5.0 and zkex 6.5.0. In the POM file I have added the following code:

<dependency>
            <groupId>classpath1</groupId>
            <artifactId>t6</artifactId>
            <version>0.9.2</version>
            <scope>system</scope>
            <systemPath>/home/ants/at6/CLASSPATH/jasperreports-4.5.1.jar</systemPath>
</dependency>

When I run the application however, I get the following error:

org.zkoss.zk.ui.metainfo.DefinitionNotFoundException: file:/home/ant...ar_exploded/pages/main.zul:231:105: Component definition not found: jasperreport in [LanguageDefinition: xul/html]

I have tried to change versions of zk and zkex, but I still get the same message. Do you know here the problem may lay in? Thanks in advance

delete flag offensive retag edit

Comments

r u using zk EE or ZK CE because jasper report is not free

sjoshi ( 2013-04-14 16:16:37 +0800 )edit
Be the first one to answer this question!
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
1 follower

RSS

Stats

Asked: 2013-04-13 19:13:21 +0800

Seen: 21 times

Last updated: Apr 13 '13

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More