0

sporadic error: failed to process

asked 2012-08-16 13:01:40 +0800

avidD gravatar image avidD
166 2

Dear colleagues,
every now and then I get the following error message:

org.zkoss.zk.ui.impl.DesktopImpl service:721
SCHWERWIEGEND: [Desktop z_r4i:/index.zul] client error: Failed to process
setAttr
Cannot read property 'defaultView' of undefined (TypeError)

It is displayed in a red box at the top of the screen in our application. The error is not reproducible and occurs maybe once per month given 1-2 hours using the app per day. Has anyone run into this before?

Regards,
David

delete flag offensive retag edit

3 Replies

Sort by ยป oldest newest

answered 2012-08-20 02:22:32 +0800

iantsai gravatar image iantsai
2755 1

Hi, David

which version of ZK are you using? and could you please post a bug about this issue in our tracker?

link publish delete flag offensive edit

answered 2012-08-31 14:01:54 +0800

avidD gravatar image avidD
166 2

Hi,
sorry for this very late response. I was hoping that I could isolate the code that produces the problem which was not possible yet.I filed a bug now: http://tracker.zkoss.org/browse/ZK-1327

link publish delete flag offensive edit

answered 2012-09-03 03:24:17 +0800

iantsai gravatar image iantsai
2755 1

Hi, I already forward your post to ZK support team, they might contact you very soon.

link publish delete flag offensive edit
Your reply
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow

RSS

Stats

Asked: 2012-08-16 13:01:40 +0800

Seen: 189 times

Last updated: Sep 03 '12

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More