0

first load of wcs and wpd resources with jsessionid in URI fails with 404 file not found

asked 2012-05-06 15:01:19 +0800

zeljko gravatar image zeljko
15

Hi,

i have problem hosting my ZK app online, on every first page visit a blank page is displayed.
After F5, refresh, application is started normally.

Application fails to start because page resource requests ended in 404 file not found error.
(zk.wcs, zk.wpd, zul.lang, zul.breeze)

Every first visit/request to the page,
while jsession cookie is not set,
application elements (wcs, wpd) are loaded with jsessionid parameter in URI
and several of those requests ends in 404 error.

This is also tested with basic test application, empty ZK project.
When deployed locally on tomcat 6 all runs without errors, both basic tests and real app.

I have noticed while running ZK 6.0.0, then tried with 6.0.1 and was the same, and then 5.0.11, the same problem.

Any ideas anybody?

Zeljko

delete flag offensive retag edit

4 Replies

Sort by ยป oldest newest

answered 2012-05-06 20:43:13 +0800

zeljko gravatar image zeljko
15

Guys from hosting solved this with some tomcat settings.... working fine now.

link publish delete flag offensive edit

answered 2016-04-05 13:59:14 +0800

dhuwym gravatar image dhuwym
0

I have been facing same case for long time. Could you please give me some hints to how to fix it?

Thanks & BR,

Ken

link publish delete flag offensive edit

answered 2019-11-19 01:49:36 +0800

zkulm gravatar image zkulm
100 1

Hi zeljko, which tomcat settings did you change in order to solve this issue? I am facing the same problem. Regards Philipp

link publish delete flag offensive edit

answered 2019-11-19 15:52:33 +0800

cor3000 gravatar image cor3000
4952 2 7
ZK Team

updated 2019-11-19 15:54:54 +0800

depending on your tomcat version there's either a legacy mechanism or a web.xml based configuration, summarized here:

https://fralef.me/tomcat-disable-jsessionid-in-url.html

or here

https://stackoverflow.com/questions/962729/is-it-possible-to-disable-jsessionid-in-tomcat-servlet

from tomcat 7+ add this to your web.xml, which will disable the JSESSIONID in the URL

<session-config>
   <tracking-mode>COOKIE</tracking-mode>
</session-config>
link publish delete flag offensive edit
Your reply
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
3 followers

RSS

Stats

Asked: 2012-05-06 15:01:19 +0800

Seen: 155 times

Last updated: Nov 19

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More