ZK Studio activation problem and BouncyCastleProvider as Java security provider

asked 2011-05-12 15:44:47 +0800

aponomarenko gravatar image aponomarenko
18 1

Hello, All!

I have fought with ZK Studio activation for a few hours, so I want to share found solution with all.

First of all, the environment:
- Eclipse J2EE 3.6 SR2 x64
- ZK 5.0.6
- ZK Studio 1.0.0

How the problem was looked:
I called "ZK Studio Activation" form, typed correct username/password, "Status of Actvation" progress bar appeared BUT no progress had been started and I had to skip process and close form

All Eclipse network parameters are set well - I use remote installations and updates.

In Eclipse log I saw:
"!MESSAGE null
at [org.zkoss.eclipse.services.license.core.LicenseManager]
at java.lang.String.<init>(String.java:515)
at org.zkoss.eclipse.license.util.LicenseReader.read(Unknown Source)..."


"!MESSAGE Unhandled event loop exception
java.lang.RuntimeException: java.lang.RuntimeException: cannot load any license from environment
at org.zkoss.eclipse.services.ui.ZKRegistrationUIHelper.storeUserProfile(ZKRegistrationUIHelper.java:313)..."

And the solution:
1) locate JRE which is used by Eclipse
2) go to <jre folder>/lib/security, find file java.security
3) in this file the list of security providers is provided, it's elements look like security.provider.<N>=<provider class> where N is just order number
we should add the following provider
9 - it's the next order number in the list
4) copy bcprov-jdk15-143.jar to <jre folder>/lib/ext (you can find this jar inside <eclipse folder>/plugins/org.zkoss.eclipse.services_1.0.0.v201101111416, /lib folder)
5) restart Eclipse and try to activate ZK Studio

Hope it will be helpful!


delete flag offensive retag edit

8 Replies

Sort by ยป oldest newest

answered 2011-06-02 15:31:28 +0800

crptone gravatar image crptone

Thanks so much!! These instructions worked perfectly for me.

link publish delete flag offensive edit

answered 2011-06-07 10:38:02 +0800

rautrupesh gravatar image rautrupesh

Thanks! I worked for me too.

link publish delete flag offensive edit

answered 2011-06-15 01:00:17 +0800

ashishchoudhary gravatar image ashishchoudhary
21 1

Hi All,

In my case ZK Studio is successfully getting activated but still while working in ZK web application it is giving "The function of ZK studio is disabled,please activate ZK studio".
When I re-try to activate it,its again showing the successful message.
I am using Eclipse Europa on window OS and ZK version is 3.5.2

Any kind of help will be appreciated.

link publish delete flag offensive edit

answered 2012-12-04 20:14:04 +0800

chxcxl gravatar image chxcxl

It worked for my eclipse juno.

link publish delete flag offensive edit

answered 2014-10-23 20:54:56 +0800

anass312 gravatar image anass312

Hi, I have the same problem. It has not worked for me. I dont know why ? any king of help will be appreciated.

link publish delete flag offensive edit

answered 2017-05-16 10:17:11 +0800

oscarBC gravatar image oscarBC

It worked for me, thank you!

link publish delete flag offensive edit

answered 2017-06-01 07:20:24 +0800

morganjohn gravatar image morganjohn


link publish delete flag offensive edit

answered 2023-01-28 20:50:43 +0800

JazzAfrica31 gravatar image JazzAfrica31

Could anyone help me I need a license to activate the zkbiosecurity v500 software

link publish delete flag offensive edit
Your reply
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools




Asked: 2011-05-12 15:44:47 +0800

Seen: 1,408 times

Last updated: Jan 28

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More