0

Listheader with mold="select" and listheader hangs.

asked 2010-06-24 12:42:25 +0800

Arsen gravatar image Arsen
382 5

Test code is simple
test.zul

<zk xmlns="http://www.zkoss.org/2005/zul">
    <window>
        <listbox id="listbox" mold="select">
            <listhead>
                <listheader label="header1"/>
                <listheader label="header2"/>
            </listhead>
        </listbox>
    </window>
</zk>

Try to load this page - "loading..." message appears and never gone. No error message is displayed, no exception in log files - just "loading" for eternity :-)

delete flag offensive retag edit

3 Replies

Sort by ยป oldest newest

answered 2010-06-25 00:49:12 +0800

Arsen gravatar image Arsen
382 5

Good day, samchuang.
With 5.0.3 issue can not be reproduced - it works fine.

link publish delete flag offensive edit

answered 2010-06-24 19:55:18 +0800

samchuang gravatar image samchuang
4084 4

Hi

could you test on the ZK Freshly build, you could download here

link publish delete flag offensive edit

answered 2010-06-24 12:44:03 +0800

Arsen gravatar image Arsen
382 5

Issue appears on ZK 5.0.0 CE, while ZK 3.6.4 renderers this listbox without any problems.

link publish delete flag offensive edit
Your reply
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow

RSS

Stats

Asked: 2010-06-24 12:42:25 +0800

Seen: 254 times

Last updated: Jun 25 '10

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More