0

Maven

asked 2010-06-11 06:28:51 +0800

orism gravatar image orism
24 1 3

Hi,
sorry guys, but I got some mayor problems with your Maven Repository!
1. I did not get it indexed by my Local Nexus Repository.
I think the "http://mavensync.zkoss.org/maven2//.meta/repository-metadata.xml" is missing!

2. Do you Deleted the Gmaps Artifact (that one which was located in org/zkoss/zkoss/ ) ?
In fact the whole directory is empty.

Regards

delete flag offensive retag edit

7 Replies

Sort by ยป oldest newest

answered 2010-06-11 06:32:00 +0800

orism gravatar image orism
24 1 3

And to also mention it:
Everything i could load via: http://repo1.maven.org/maven2/org/zkoss/ is pretty old!

link publish delete flag offensive edit

answered 2010-06-12 08:42:56 +0800

henrichen gravatar image henrichen
3869 2
ZK Team

http://docs.zkoss.org/wiki/How-Tos/Installation/How_to_use_ZK_Maven_Repository

link publish delete flag offensive edit

answered 2010-06-14 01:35:20 +0800

orism gravatar image orism
24 1 3

Hmm yes, I already read this multiple times.

It does not explain why Nexus & m2eclipse can't index your repository for searching artifacts.

And it also does not explain why you deleted the Gmaps Artifact. And the only Gmaps Artifact I can find is out of date: (http://mavensync.zkoss.org/maven2/org/zkoss/zkforge/gmapsz/).

Regards

link publish delete flag offensive edit

answered 2010-06-15 17:09:37 +0800

matuso gravatar image matuso
3

Hi,

I had troubles with Gmaps component from maven versions. First, I downloaded the "traditional" (Nexus?) artifacts with m2eclipse assistance. They worked in the most, but when I add a <gmaps> component in a zul file, an invalid or not known html/zul tag error raises. Then, I added the zkoss repositories (http://mavensync.zkoss.org/maven2) and downloaded ZK again from them. It worked as in the first try, but now when I use the <gmaps> tag it raises a different error: "org.zkforge.gmaps.Gmaps" class is not found. After that, I noticed the Gmap artifact is very old (2.0-3 is the last version), so downloaded the 2.0_50 version from zkforge. Now it does'n raises any error, but neither works (no map is loaded).

Finally I would like to say that I researched in many RIA technologies (OpenLaszlo, GWT, Echo2, among others) and found ZK very interesting because it allows to build good looking applications fast in Java, defining the UI declaratively and including a lot of widgets out-of-the-box. It's a shame that Maven integration doesn't fully work, specially when integration with other frameworks like Spring is promoted.

Best Regards.

link publish delete flag offensive edit

answered 2010-09-09 05:23:25 +0800

mfehlau gravatar image mfehlau
45

Hi,

i want to use the ZK CE-Maven repository aswell, but

09.09.10 12:11:01 MESZ: Unable to update index for ZK CE|http://mavensync.zkoss.org/maven2: Resource nexus-maven-repository-index.properties does not exist

is there any way to get ZK 5.0.4 with m2eclipse?

Regards

link publish delete flag offensive edit

answered 2010-09-10 03:32:45 +0800

terrytornado gravatar image terrytornado flag of Germany
9393 3 7 16
http://www.oxitec.de/

Some folder names have been changed. Have a look here.

link publish delete flag offensive edit

answered 2010-09-11 05:08:04 +0800

mfehlau gravatar image mfehlau
45

thank you terrytornado,

i have read this site twice. I would like to use the ZK CE version with maven path "http://mavensync.zkoss.org/maven2". But in this directory, the m2eclipse plugin could not find the file nexus-maven-repository-index.properties ... is there any chance to enable the index without this file.

regards

link publish delete flag offensive edit
Your reply
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow

RSS

Stats

Asked: 2010-06-11 06:28:51 +0800

Seen: 1,630 times

Last updated: Sep 11 '10

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More