Urget: GAE session size is exceeding 1000000 characters

asked 2010-04-02 20:06:54 +0800

kesavkolla gravatar image kesavkolla
180 3

I am using ZK 5.0.1 on Google Application Engine. I am getting the error in GAE that

java.lang.IllegalArgumentException: string property _values is too long. It cannot exceed 1000000 characters

My page is not that huge I have around 20 controls on the page that's about it. I am not even doing anything fancy with session it's just simple CRUD screen.

Why isn't the session clearing after page is unloaded? Is there any setting that controls this?

Please help me as my app is in pilot testing and I am getting this error more frequently now.

Thanks in advance

delete flag offensive retag edit

3 Replies

Sort by ยป oldest newest

answered 2010-04-03 08:18:37 +0800

iantsai gravatar image iantsai
2755 1

what is that property?

can you point out which part of ZK cause that BIG String? I need some clue to verify the problem.

link publish delete flag offensive edit

answered 2010-04-05 10:59:19 +0800

kesavkolla gravatar image kesavkolla
180 3

GAE serializes the session into data store. So I am getting the above exception when the session is huge. Why is the session getting huge? As per my application needs I don't keep anything in session. The session getting bigger and bigger means the page unload is not working properly. Any hints on how to trap this?

link publish delete flag offensive edit

answered 2010-04-07 20:36:41 +0800

iantsai gravatar image iantsai
2755 1

Every Browser request which request a zul page will create a ZK component tree which are a java instances stored in session.
While browser closing, zk client engine will try to notify server that the desktop should be cleaned, but there's no guarantee for this step because Browser implementation and possible OS level termination.

So, the best way to limit the size of session that a single user can used, is to limit the amount of desktop that user can create.

please refer to this article: zk.xml session config

you can specify these settings to limit user quota per session:


link publish delete flag offensive edit
Your reply
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools




Asked: 2010-04-02 20:06:54 +0800

Seen: 357 times

Last updated: Apr 07 '10

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More