0

Disabling some messages

asked 2009-11-04 20:56:22 +0800

esdlbt gravatar image esdlbt
30

Is there any way to disable the messages that appear when a page is loading, for example the message loading zk.wcs, etc and the small icon on the left -> powered by ZK

I'm using ZK 5.0RC

delete flag offensive retag edit

7 Replies

Sort by ยป oldest newest

answered 2009-11-04 20:56:44 +0800

esdlbt gravatar image esdlbt
30

sorry the icon is on the right

link publish delete flag offensive edit

answered 2009-11-05 03:43:54 +0800

tomyeh gravatar image tomyeh
610 1 3
http://blog.zkoss.org ZK Team

Sure, it is controlled by a CSS name called z-initing.

link publish delete flag offensive edit

answered 2013-06-22 10:55:43 +0800

andij62 gravatar image andij62
303 1 7

I found this old question. I set the css but it does not work. Why? I am using 6.5.2

.z-initing { background-image: none; }

Regards Andi

link publish delete flag offensive edit

answered 2013-06-24 17:19:29 +0800

andij62 gravatar image andij62
303 1 7

can someone help me? What is wrong?

link publish delete flag offensive edit

answered 2013-07-18 20:30:16 +0800

mcprol gravatar image mcprol
42

Try the !important property in the css rule.

I have changed the icon with

.z-initing { width: 50px !important; height: 72px !important; background-image: url('../img/norm/powered.png') !important; }

and it works for me. I'm using zk 6.5.0

link publish delete flag offensive edit

answered 2013-07-19 19:38:29 +0800

andij62 gravatar image andij62
303 1 7

Thanks for the info! I have another Question.

During the init-prozess the background is grey and the "processing" info is shown. I will set the background to white and disable the "processing" info. What should i do?

link publish delete flag offensive edit

answered 2013-07-30 10:59:08 +0800

andij62 gravatar image andij62
303 1 7

updated 2013-07-30 11:03:27 +0800

This code dont work, the image is already shown. Why? What is wrong? I'm using 6.5.2 CE

<zk> <window border="normal" width="100%" height="100%"> <style dynamic="true"> .z-initing { background-image: none !important; }
</style>

<label value="You are using: ${desktop.webApp.version}"/> </window> </zk>

link publish delete flag offensive edit
Your reply
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow

RSS

Stats

Asked: 2009-11-04 20:56:22 +0800

Seen: 451 times

Last updated: Jul 30 '13

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More