zul cache control

asked 2006-02-22 19:23:22 +0800

admin gravatar image admin
18691 1 10 130
ZK Team

Orignial message at:

By: notzippy


Probably somethng obvious, but i havent been able to find the following in any of the documentation or the forums

How do you change the cache control setting for a http://localhost:8080/test.zul ?

For example if I go to the above url once, then modify and save the file "test.zul"
then go to the same url it doesnt show any of the changes I made (even for a different session, until I restart the web application).

Is there a way to turn of the cache control ?

delete flag offensive retag edit

2 Replies

Sort by ยป oldest newest

answered 2018-06-26 11:05:52 +0800

matthung gravatar image matthung
3 2

Set org.zkoss.web.classWebResource.cache to false in zk.xml

<?xml version="1.0" encoding="UTF-8"?>
link publish delete flag offensive edit

answered 2006-02-23 02:16:44 +0800

admin gravatar image admin
18691 1 10 130
ZK Team

Orignial message at:

By: tomyeh

ZK detects whether a file is changed automatically (by use of timestamp).

However, to have better performance, it checks the timestamp every 5 seconds.
So, if you press reload after saving the file for at least 5 seconds, you shall see the new content. And, there is a log message in your log files (depending your configuration).

link publish delete flag offensive edit
Your reply
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools




Asked: 2006-02-22 19:23:22 +0800

Seen: 852 times

Last updated: Jun 26 '18

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More