Tried to use xhtml on .zul file, but got error, using native on .zul, it's fine, v9.6.0-jakarta

asked 2023-11-09 10:36:11 +0800

BenLimanto gravatar image BenLimanto
1 1

updated 2023-11-09 11:01:40 +0800

Hello, I'm trying making a xhtml based on the docs and got org.zkoss.zk.ui.metainfo.DefinitionNotFoundException: Language not found: xhtml, but I got error that xhtml isn't found. I'm quite confused. I also tried using native lang on zul, and it work as it's... xmlns:n="native", but xmlns:h="xhtml" cause error...

I have these dependency of ZKPlus, ZKBind, ZKSpringBoot.

org.zkoss.zk.ui.metainfo.DefinitionNotFoundException: Language not found: xhtml at org.zkoss.zk.ui.metainfo.LanguageDefinition.lookup(LanguageDefinition.java:259) ~[zk-9.6.0-jakarta-Eval.jar:9.6.0-migrated-1.0.0] at org.zkoss.zk.ui.metainfo.Parser.parseItem(Parser.java:908) ~[zk-9.6.0-jakarta-Eval.jar:9.6.0-migrated-1.0.0] at org.zkoss.zk.ui.metainfo.Parser.parseItems(Parser.java:679) ~[zk-9.6.0-jakarta-Eval.jar:9.6.0-migrated-1.0.0] at org.zkoss.zk.ui.metainfo.Parser.parseItem(Parser.java:1091) ~[zk-9.6.0-jakarta-Eval.jar:9.6.0-migrated-1.0.0] at org.zkoss.zk.ui.metainfo.Parser.parse(Parser.java:242) ~[zk-9.6.0-jakarta-Eval.jar:9.6.0-migrated-1.0.0] at org.zkoss.zk.ui.metainfo.Parser.parse(Parser.java:148) ~[zk-9.6.0-jakarta-Eval.jar:9.6.0-migrated-1.0.0] at org.zkoss.zk.ui.metainfo.PageDefinitions.getPageDefinitionDirectly(PageDefinitions.java:96) ~[zk-9.6.0-jakarta-Eval.jar:9.6.0-migrated-1.0.0] at org.zkoss.zk.ui.http.ZumlExtendlet$ZumlLoader.parse(ZumlExtendlet.java:212) ~

I even follow the docs /wiki/ZUML_Reference/ZUML/Languages using full path of the xml http url, but failed...

And the code is following as the docs. Any help is appreciated. Thank you

I tried using the fiddle, and it's working as it's

zkfiddle dot org/sample/10bkrh5/1-Another-new-ZK-fiddle

It makes me confused tbh

I have 9.6.0-jakarta edition of zkoss. Any help really appreciated. Thank you

delete flag offensive retag edit

1 Answer

Sort by ยป oldest newest most voted

answered 2023-11-09 11:22:57 +0800

BenLimanto gravatar image BenLimanto
1 1

Udh, the dependencies need


add to the pom.xml... well...

This is solved then.

link publish delete flag offensive edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools




Asked: 2023-11-09 10:36:11 +0800

Seen: 2 times

Last updated: Nov 09

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More