0

Annoying warning in log: Component jasperreport ignored

asked 2023-01-24 18:09:57 +0800

holos gravatar image holos
1

updated 2023-01-24 18:10:21 +0800

After switching to ZK-EE we always get this warning in our startup log:


o.z.zk.ui.metainfo.DefinitionLoaders: Component jasperreport ignored. Reason: unable to load org.zkoss.zkex.zul.Jasperreport due to java.lang.NoClassDefFoundError: net/sf/jasperreports/engine/JRDataSource

We are using zk-ee 9.6.1 via zkspringboot-starter 2.3.1.

delete flag offensive retag edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2023-01-30 15:55:11 +0800

hawk gravatar image hawk
3073 1 5
http://hawkphoenix.blogsp... ZK Team

this is an expected warning. Since 9.6.0 zk doesn't include jasper report jar by default. So the message just reminds you if you want to use the component <jasperreport>, you need to include its dependency manually.

see https://www.zkoss.org/wiki/ZKComponentReference/DiagramsandReports/Jasperreport#Including_Dependency

link publish delete flag offensive edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow

RSS

Stats

Asked: 2023-01-24 18:09:57 +0800

Seen: 5 times

Last updated: Jan 30

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More