0

tomcat and java version for zk framework

asked 2022-10-12 16:30:24 +0800

nome gravatar image nome
7 2

Hi guys,

Does zk.version 9.6.0 support tomcat 10.0.27 or 10.1.1 with jdk 11? or can you provide the require regarding the compatibility of this version?

Thanks,

delete flag offensive retag edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2022-10-12 16:34:13 +0800

MDuchemin gravatar image MDuchemin
2298 1 5
ZK Team

Hello there,

The only real concern you will have here is that tomcat 10 is jakarta based (not java based). When you are choosing your zk version, just make sure you are using the -jakarta one.

I will recommend checking your specific server here: https://en.wikipedia.org/wiki/JakartaEE#Certifiedreferencing_runtimes

and for general jakarta concerns, you have zk's own documentation here: https://www.zkoss.org/wiki/ZKInstallationGuide/BeforeYouStart/NewtoJakartaServlet#Whichservletversiondoesmywebserver_support.3F

and here: https://www.zkoss.org/wiki/ZKInstallationGuide/ServletSpecification/GettingstartedwithZK-Jakarta

link publish delete flag offensive edit

Comments

fyi, zk supports jakarta from 9.6.0 and later.

MDuchemin ( 2022-10-12 16:35:06 +0800 )edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
1 follower

RSS

Stats

Asked: 2022-10-12 16:30:24 +0800

Seen: 4 times

Last updated: Oct 12

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More