zk-archetype-webapp has no properties, why?

asked 2022-05-29 08:37:14 +0800

sntg99 gravatar image sntg99
1 1

updated 2022-05-30 20:10:15 +0800

Hello there. I'm trying to get into ZK in "Create and run your first ZK app" tutorial: but I got stuck on the part where I have to create a Maven project. The problem is... zk-archetype-webapp has no properties at all and I already read the "The property zk-version-since might be missing." part of the documentation, but it didn't help because I have a kinda different of error message when I tried to press in 'Add' and type manually the details by my own: " 'Creating zk-archetype-webapp' has encountered a problem. Could not resolve archetype org.zkoss:zk-archetype-webapp:9.6.0 from any of the configured repositories." Could not resolve artifact org.zkoss:zk-archetype-webapp:jar:9.6.0 org.zkoss:zk-archetype-webapp:jar:9.6.0 failed to transfer from /content/repositories/releases during a previous attempt. This failure was cached in the local repository and resolution is not reattempted until the update interval of local-releases has elapsed or updates are forced.

Thanks in advance and sorry for my bad English.

delete flag offensive retag edit

3 Answers

Sort by ยป oldest newest most voted

answered 2022-05-31 18:27:56 +0800

MDuchemin gravatar image MDuchemin
2515 1 6
ZK Team


From the error message provided, it appear that your maven instance tried to download the archetype org.zkoss:zk-archetype-webapp:9.6.0, but failed to do so.

This caused the download failure to be stored in your .m2 cache, and now the archetype shows as missing.

The first thing you can try to do is to force an update of the archetype (assuming the issue was just a network error or similar)

First, go to Eclipse menu > window > preferences > Maven > archetypes.

Make sure that the ZK Archetypes catalog exist here. Click on the ZK archetypes catalog, go to edit, and then click on "verify" to make sure that the catalog is resolved.

After clicking on "verify" you should get a "catalog contains X archetypes" near the top of that specific window.

If that resolves properly, try to create a project from archetype again.

If it does not, we can check other possible issues.

link publish delete flag offensive edit

answered 2022-06-05 06:43:56 +0800

sntg99 gravatar image sntg99
1 1

updated 2022-06-05 06:45:33 +0800

Hello! Thanks for you answer.

Now I'm having issues in "Run the application" part because my console is throwing this error when I go to Run As > Maven install:

[INFO] Scanning for projects... [INFO] [INFO] ----------------------------< com.foo:demo >---------------------------- [INFO] Building The demo Project 0.0.1-SNAPSHOT [INFO] --------------------------------[ war ]--------------------------------- [INFO] [INFO] --- jetty-maven-plugin:10.0.5:stop (default-cli) @ demo --- [INFO] ------------------------------------------------------------------------ [INFO] BUILD FAILURE [INFO] ------------------------------------------------------------------------ [INFO] Total time: 0.871 s [INFO] Finished at: 2022-06-04T19:38:44-03:00 [INFO] ------------------------------------------------------------------------ [ERROR] Failed to execute goal org.eclipse.jetty:jetty-maven-plugin:10.0.5:stop (default-cli) on project demo: Please specify a valid port -> [Help 1] [ERROR] [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch. [ERROR] Re-run Maven using the -X switch to enable full debug logging. [ERROR] [ERROR] For more information about the errors and possible solutions, please read the following articles:

link publish delete flag offensive edit

answered 2022-06-06 15:57:41 +0800

MDuchemin gravatar image MDuchemin
2515 1 6
ZK Team


Are you running the "maven install" goal on the application project?

The "maven install" goal is not designed to start a web project. It is used to store a completed project inside of your local maven cache (.m2 folder), in order to allow other projects to use that installed jar as a dependency.

In order to run the ZK application from Eclipse, you have a few choices:

If your pom file declares the maven jetty plugin, you can start the project by using the jetty:run goal in run as > maven build ...

sample here:

        <!-- Run with Jetty -->

If you have the eclipse jetty plugin installed, you can run the project directly with it. You can do this with run as > run jetty

If you have a local web server (such as apache tomcat), you can link that webserver to your Eclipse in the preference menu Window > preferences > server > runtime environments > add ...

This allow you to use the "run on server" option in "run as"

link publish delete flag offensive edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

1 follower



Asked: 2022-05-29 08:37:14 +0800

Seen: 12 times

Last updated: Jun 06 '22

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More