0

How to enable past dates in datebox control

asked 2021-12-02 17:19:10 +0800

reamerit gravatar image reamerit
3 1

Hi support team: I am using zk 9.0.0. In my application, the past dates are all disabled by default(can not clickable). How can I enable them? I tried to add constrain="after 19700101" on the databox control. But it does not work.

Thanks

delete flag offensive retag edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-12-07 18:23:26 +0800

hawk gravatar image hawk
2941 1 5
http://hawkphoenix.blogsp... ZK Team

By default, datebox doesn't limit you to select a past date, you can see https://www.zkoss.org/zkdemo/input/dateandtime_picker

There is must be somewhere in your project that sets the datebox with a constraint 'no past' (https://www.zkoss.org/wiki/ZKComponentReference/Input/Datebox#Constraint) Maybe in lang-addon.xml(there is a way to set component attribute in application-scope, see https://www.zkoss.org/wiki/ZKClient-sideReference/Language_Definition/component#property), or any initialization code. I need to check the source code to find the root cause.

link publish delete flag offensive edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow

RSS

Stats

Asked: 2021-12-02 17:19:10 +0800

Seen: 3 times

Last updated: Dec 07 '21

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More