0

Autocomplete=off is being ignored by Safari

asked 2021-05-07 23:40:56 +0800

jordy31 gravatar image jordy31
1

I am trying to turn autofill off for a date field in a textbox that I have. I have tried adding autofill="off" in the form attribute and in the textbox attribute. Tried changing autofill="off" to autofill="false" to try and trick Safari but that did not work either. Is there anyway to turn autofill off completely for textbox fields? Or does anyone know a workaround for this?

delete flag offensive retag edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-05-10 11:23:17 +0800

cor3000 gravatar image cor3000
5920 2 7
ZK Team

this seems to be a common behavior with Safari and HTML Forms, a quick search produces several similar questions: e.g. https://stackoverflow.com/questions/43058018/how-to-disable-autocomplete-in-address-fields-for-safari

So this problem is not ZK specific: however if you find a working HTML approach we can help how to integrate this into a zk page.

link publish delete flag offensive edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
1 follower

RSS

Stats

Asked: 2021-05-07 23:40:56 +0800

Seen: 4 times

Last updated: May 10

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More