0

Datebox width appended differently when using zk 9.5.1-Eval

asked 2021-05-03 17:39:36 +0800

rmalik gravatar image rmalik
31 2

Hi all,

We are trying to upgrade zk along the way and check if there are any differences. It seems that the datebox does appends the width differently, when using ZK 9.5.1-Eval.

Here is an example which shows where the datebox width is appended (ZK 8.6.0.1): image

Here is an example which shows that the datebox is appended differently (ZK 9.5.1-Eval) :

image

I tried using newer versions like, 9.6.0.FL.20210429-Eval. But my IntellIJ complains: Cannot load /home/remie/workspaceintellij/frontend/target/webUI/META-INF/context.xml: /home/remie/workspaceintellij/frontend/target/webUI/META-INF/context.xml (No such file or directory) and thus it cannot load it correctly.

Kind regards,

Remie

delete flag offensive retag edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2021-05-04 16:48:22 +0800

cor3000 gravatar image cor3000
5995 2 7
ZK Team

updated 2021-05-04 16:48:41 +0800

I can't explain why your IDE has a particular issue with a FL version, especially since context.xml which is not a file required by ZK.

When I use a FL version in IntelliJ there's no such problem, so this is environment specific.

However the different sizing could be explained by a new feature added in zk 9.0.0 -> CSS Flex support

However that depends on the components surrounding of your datebox ... here my test example: https://zkfiddle.org/sample/3i9v0ho/2-datebox

As you can see there are 2 databoxes one default (flex enabled) and one with disabled css flex. In my case both have the same width.

If you can add what's missing to reproduce your problem (and post the updated zkfiddle link) I can have a second look, and provide a solution of post a bug.

link publish delete flag offensive edit
0

answered 2021-06-11 15:17:06 +0800

rmalik gravatar image rmalik
31 2

Hi Cor3000,

I really can not get past the context.xml error. The ZK version that i used is version 9.6.0.FL.20210610-Eval, the latest.

I noticed that when i switch from version 9.5.1 to a higher which includes Jakarta, it fails. It seems that version includes some extra stuff.

I even tried the steps described in this tutorial

I can edit the fiddle and test it out, but if i can not run the same version locally, then it is of no use.

Is there anything that i can supply, to you can look further? Maybe add my pom.xml file so you can look at the differences?

link publish delete flag offensive edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
1 follower

RSS

Stats

Asked: 2021-05-03 17:39:36 +0800

Seen: 10 times

Last updated: Jun 11

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More