0

Error related to ZK85Icons.woff?v=4.7.0 not found while Upgrading ZK version from ZK 6.5.4 to ZK 9.1.0

asked 2021-04-10 05:21:41 +0800

apatil gravatar image apatil
1

Hi,

In our jave spring based project we were using ZK 6.5.4. we have used custom themes. and now we are upgrading version to zk 9.1.0.

with zk 6.5.4 each custom them folder having zk.wcs file with stylesheet href="~./...../zul/css/norm.css.dsp"/>

and now with new zk version 9.1.0 zk.wcs also including stylesheet href="~./...../zul/font/font-awesome.css.dsp"/> along with stylesheet href="~./...../zul/css/norm.css.dsp"/>

This font-awesome.css.dsp file includes ZK85Icons.woff?v=4.7.0.

The issue I am facing is regarding ZK85Icons font file. while building and running the project with new zk 9.1.0, in web console it throws an error 404, file resource not found.

Though I tried serving woff as static resource in web.xml file of application: <servlet-mapping>
<servlet-name>default</servlet-name> <url-pattern>*.woff</url-pattern> </servlet-mapping>

can you please advise on this.

Thanks in advance..!!

delete flag offensive retag edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-04-12 17:07:02 +0800

MDuchemin gravatar image MDuchemin
1901 1 5
ZK Team

Hi there,

The ZK85Icons.woff file is served directly by the ZK update servlet (DHtmlUpdateServlet) through a url starting with /zkau/..., from compiled less file. You don't need to add a specific url pattern, or an entry to the default servlet. This will cause the url to fail, since the font file is not on the web path, but in the web resources accessed by zkau.

(note: your ZK update servlet should be mapped to <url-pattern>/zkau/*</url-pattern> )

In order to load this file, I'd recommend disabling the mapping done on web.xml first. Then, if the client still cannot find the file, make sure that you have the correct version of the zul.jar in your dependencies.

It should contain this file located at: [zul.jar]/web/zul/less/font/ZK85Icons.woff Assuming the zul.jar dependency is on the same version, and the file is still not available at client side, try to force a full clear cache and refresh of the browser for this URL. (you can do this with ctrl+F5 in most browsers) Sometime, custom values can get stuck and forcing a full clear cache and refresh is a good way to get a "clean state".

Let me know if you still encounter this issue after that.

link publish delete flag offensive edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
1 follower

RSS

Stats

Asked: 2021-04-10 05:21:41 +0800

Seen: 6 times

Last updated: Apr 12

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More