0

aux header dropped, column disappears

asked 2021-03-05 22:08:55 +0800

BenBrandNLD gravatar image BenBrandNLD
1

updated 2021-03-06 04:04:44 +0800

I am creating a grid of monthly dates for planning purposes.

I build this dynamically based on the current month and allow the user to jump up/down a month. There are three header rows, the top spanning the week (7 columns) and then 2 auxheader rows each spanning 1 column showing the date and day of the week.

Towards the end of the month, a column is "dropped" from view, although it is built and added to the parent like all the others. This is random towards the end of the month, I cannot find any reason why it would be that specific column, more so because it comes and goes and is a different column each time.

This seems to be a BUG. I am using the latest release in Maven and Chrome that is up to date/patched. Edge gives the same results.

UPDATE

I did another test and added the columns/auxheaders not via a programmatic loop but hardcoded the whole thing into the zul and the java. The SAME columns are dropped out of the headers. Wtf, the SAME ones!! It is not random because as you move up/down in the month the same columns are dropped in both use-cases.

Somewhere the auxheaders list gets corrupted and just ignores a column. The column (kind of) exits when you add a row, so it is in the auxheaders.

Happy to attach the test files I built to analyze this.

This is a BUG, so how do I raise a bug ticket?

delete flag offensive retag edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2021-03-17 17:18:15 +0800

BenBrandNLD gravatar image BenBrandNLD
1

It turned out this was not a bug, I created X# auxheader(s), but only added X# - 1 columns to the grid and this will screw up the auxheaders, they will have to drop one somewhere. This was rather random it seemed, it did not drop the final auxheader. But, not a bug, programmer error.

link publish delete flag offensive edit

Comments

Thanks for your confirmation. :)

hawk ( 2021-03-18 09:08:35 +0800 )edit
0

answered 2021-03-10 22:01:21 +0800

BenBrandNLD gravatar image BenBrandNLD
1

Apologies, OOTO for a few days.

Thanks, I have opened a bug ticket: ZK-4818. here I have attached a java class and ZUL file to reproduce this error.

Thanks! Ben

link publish delete flag offensive edit

Comments

Hi, we reviewed ZK-4818 and added a comment to it, can you check that in the tracker first?

jeanher ( 2021-03-17 09:01:56 +0800 )edit
0

answered 2021-03-08 10:55:12 +0800

hawk gravatar image hawk
2785 1 5
http://hawkphoenix.blogsp... ZK Team

updated 2021-03-08 10:55:35 +0800

Since the situation sounds complicated, and it's hard to reproduce the bug through the description. Could you post the related code (zul, java) and the steps to reproduce it at https://tracker.zkoss.org/? Or use http://zkfiddle.org/

So that it can help us efficiently understand what you describe. Thank you.

link publish delete flag offensive edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
1 follower

RSS

Stats

Asked: 2021-03-05 22:08:55 +0800

Seen: 10 times

Last updated: Mar 17

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More