0

Javascript error when loading an index.zul page

asked 2020-10-14 19:32:03 +0800

softteam gravatar image softteam
120 8

Hello,

Sometimes we are getting this error when trying to load an index.zul page:

image description

We are using ZK 9.1. version. Any recommendations?

Thank you, Javier

delete flag offensive retag edit

Comments

ideally provide a runnable example, or if that's not possible provide the some additional error information, such as the relevant variable values leading to this error.

cor3000 ( 2020-10-15 16:43:29 +0800 )edit

it sounds like a color value contains an '!' the values of wrap and elem seem relevant here. somewhere they contain a syntax error

cor3000 ( 2020-10-15 16:46:40 +0800 )edit

Could you also post the full stacktrace? Currently just seeing the breakpoint from the screenshot. Having the full stack of the error would help identifying when it happens.

MDuchemin ( 2020-10-15 19:49:56 +0800 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2020-10-21 22:04:23 +0800

softteam gravatar image softteam
120 8

Hi everyone,

The relevant values information are:

wrap[1] = "" wrap[2] = "" jQuery.htmlPrefilter( elem ) =

<div id="zk_proc"><div id="zk_proc-m" class="z-modal-mask" style="left:0px;top:0px"></div><div id="zk_proc-t" class="z-loading" style="left:0px;top:0px"><div class="z-loading-indicator"><span class="z-loading-icon"></span> Procesando...</div></div></div>

The call stack is:

image description

And the link of the resource is:

http://localhost:8080/StsCampanyas/zkau/web/4e7c1a4/js/zk.wpd

Thank you,

Javier

link publish delete flag offensive edit
0

answered 2020-10-23 11:36:42 +0800

cor3000 gravatar image cor3000
5868 2 7
ZK Team

updated 2020-10-23 12:00:55 +0800

Thanks for the screen shot, the stack trace shows something you might try. From what I see there is a custom zUtl.progressbox implementation defined in your login.zul.

image description

Just to isolate the problem a bit more, please comment out the custom zUtl.progressbox function in your login.zul to use ZK's built-in progressbox. If the problem goes away, then you already know where to focus your debugging efforts ;).

If this doesn't help you can provide a runnable example, ideally on https://zkfiddle.org, reproducing the issue. So we can have a look on our side. You can also contact our support if you can't share your code in public.

(Another maybe related thing I found was the same error in a different library. https://github.com/bgrins/spectrum/issues/291 Do you happen to include color inputs in your page or use this spectrum.js library?)

Also it is possible to trigger this error using by executing the following code in your browser's console, so that's also something to watch out for.

document.body.innerHTML = '<input type="color" value="!"></input>'
link publish delete flag offensive edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
2 followers

RSS

Stats

Asked: 2020-10-14 19:32:03 +0800

Seen: 14 times

Last updated: Oct 23 '20

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More