0

Deployment on Linux server by IDEA,Browser error: ZK is not defined

asked 2020-09-07 20:25:01 +0800

zl gravatar image zl
1

updated 2020-09-07 20:26:15 +0800

Why does ZKOSS run well in local idea, but it reports an error when deployed to a Linux server. Uncaught ReferenceError: zk is not defined

     Failed to load resource: net::ERR_CONTENT_LENGTH_MISMATCH
     zul.lang.wpd:1 Uncaught ReferenceError: zk is not defined
     at zul.lang.wpd:1
     at zul.lang.wpd:72
     zkbind.wpd:1 Uncaught ReferenceError: zk is not defined
     at zkbind.wpd:1
    login.zul:17 Uncaught ReferenceError: zk is not defined
     at login.zul:17
     /favicon.ico:1 Failed to load resource: the server responded with a status of 404 ()

error:

<!-- ZKOSS CE -->
    <dependency>
        <groupId>org.zkoss.zk</groupId>
        <artifactId>zkbind</artifactId>
        <version>${zk.version}</version>
    </dependency>
    <dependency>
        <groupId>org.zkoss.zk</groupId>
        <artifactId>zul</artifactId>
        <version>${zk.version}</version>
    </dependency>
    <dependency>
        <groupId>org.zkoss.zk</groupId>
        <artifactId>zkplus</artifactId>
        <version>${zk.version}</version>
    </dependency>
    <dependency>
        <groupId>org.zkoss.zk</groupId>
        <artifactId>zhtml</artifactId>
        <version>${zk.version}</version>
    </dependency>
    <dependency>
        <groupId>org.zkoss.common</groupId>
        <artifactId>zweb</artifactId>
        <version>${zk.version}</version>
    </dependency>
    <dependency>
        <groupId>org.zkoss.zk</groupId>
        <artifactId>zkspring-core</artifactId>
        <version>4.0.0</version>
    </dependency>
    <dependency>
        <groupId>org.zkoss.zkforge</groupId>
        <artifactId>ckez</artifactId>
        <version>4.11.1.1</version>
    </dependency>
delete flag offensive retag edit

Comments

it's hard to tell what went wrong during your war packaging or deployment on your server. I personally run zk withing idea and on linux servers every day and it works here. I assume a jar is missing in your war file. Can you provide the full source so I can build your project myself?

cor3000 ( 2020-09-16 09:19:22 +0800 )edit

If you can't share any details in public, please contact our support: https://www.zkoss.org/support

cor3000 ( 2020-09-16 09:22:09 +0800 )edit
Be the first one to answer this question!
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
1 follower

RSS

Stats

Asked: 2020-09-07 20:25:01 +0800

Seen: 2 times

Last updated: Sep 07

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More