0

Theme iceblue and css adjustments

asked 2020-07-15 21:58:34 +0800

andij62 gravatar image andij62
307 1 7

updated 2020-07-15 22:06:12 +0800

Hello everybody,

i use the iceblue theme and change the colors of several components to a red tone using css. When my app loads, the components briefly appear in blue before they are displayed in red. How can I prevent this without adapting the theme to myself? Or is it possible to change the basic color of the theme from blue to a red tone with little effort?

Regards Andi

delete flag offensive retag edit

5 Answers

Sort by ยป oldest newest most voted
1

answered 2020-07-21 11:19:38 +0800

MDuchemin gravatar image MDuchemin
1743 1 5
ZK Team

It looks like zklessc wasn't installed. Have you ran npm install on that project as described in the readme?

link publish delete flag offensive edit

Comments

1

that was the mistake! Now it worked. Thank you!

andij62 ( 2020-07-29 16:11:25 +0800 )edit
0

answered 2020-07-16 10:56:06 +0800

MDuchemin gravatar image MDuchemin
1743 1 5
ZK Team

Hi there,

customizing a theme is not too hard if you only plan to replace colors. You can check this document and see if that work for you: guide here

Regarding the flickering during load: That's an consequence of how your browser loads scripts an styles after the page has started rendering. When the page content is received, the page will send a request to retrieve the linked stylesheet. Once the style is received, it will be applied to the page, but that might be anywhere from almost instantly to a a few seconds if the network connection is bad.

You can mitigate some of that by adding the style content in the header of the initial response. One way to do that is to use a processing instruction from the zul file.

Another option is to set the CSS from lang-addon (similar method, except it can work globaly instead of a page per page basis)

link publish delete flag offensive edit
0

answered 2020-07-17 22:59:03 +0800

andij62 gravatar image andij62
307 1 7

Hi there,

I have adjusted the theme, but I get the following error message when creating the new theme:

[INFO] --- exec-maven-plugin:1.6.0:exec (compile-less) @ iceblue ---

npm ERR! code E404 npm ERR! 404 Not Found: [email protected]

npm ERR! A complete log of this run can be found in: npm ERR! /Users/andrel-dev/.npm/logs/2020-07-17T144718693Z-debug.log Die Installation von [email protected] ist mit dem Code 1 fehlgeschlagen [ERROR] Command execution failed. org.apache.commons.exec.ExecuteException: Process exited with an error: 1 (Exit value: 1) at org.apache.commons.exec.DefaultExecutor.executeInternal (DefaultExecutor.java:404) at org.apache.commons.exec.DefaultExecutor.execute (DefaultExecutor.java:166) at org.codehaus.mojo.exec.ExecMojo.executeCommandLine (ExecMojo.java:804) at org.codehaus.mojo.exec.ExecMojo.executeCommandLine (ExecMojo.java:751) at org.codehaus.mojo.exec.ExecMojo.execute (ExecMojo.java:313) at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo (DefaultBuildPluginManager.java:137) at org.apache.maven.lifecycle.internal.MojoExecutor.execute (MojoExecutor.java:210) at org.apache.maven.lifecycle.internal.MojoExecutor.execute (MojoExecutor.java:156) at org.apache.maven.lifecycle.internal.MojoExecutor.execute (MojoExecutor.java:148) at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject (LifecycleModuleBuilder.java:117) at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject (LifecycleModuleBuilder.java:81) at org.apache.maven.lifecycle.internal.builder.singlethreaded.SingleThreadedBuilder.build (SingleThreadedBuilder.java:56) at org.apache.maven.lifecycle.internal.LifecycleStarter.execute (LifecycleStarter.java:128) at org.apache.maven.DefaultMaven.doExecute (DefaultMaven.java:305) at org.apache.maven.DefaultMaven.doExecute (DefaultMaven.java:192) at org.apache.maven.DefaultMaven.execute (DefaultMaven.java:105) at org.apache.maven.cli.MavenCli.execute (MavenCli.java:957) at org.apache.maven.cli.MavenCli.doMain (MavenCli.java:289) at org.apache.maven.cli.MavenCli.main (MavenCli.java:193) at jdk.internal.reflect.NativeMethodAccessorImpl.invoke0 (Native Method) at jdk.internal.reflect.NativeMethodAccessorImpl.invoke (NativeMethodAccessorImpl.java:62) at jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke (DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke (Method.java:566) at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced (Launcher.java:282) at org.codehaus.plexus.classworlds.launcher.Launcher.launch (Launcher.java:225) at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode (Launcher.java:406) at org.codehaus.plexus.classworlds.launcher.Launcher.main (Launcher.java:347) [INFO] ------------------------------------------------------------------------ [INFO] BUILD FAILURE [INFO] ------------------------------------------------------------------------ [INFO] Total time: 3.676 s [INFO] Finished at: 2020-07-17T16:47:18+02:00 [INFO] ------------------------------------------------------------------------ [ERROR] Failed to execute goal org.codehaus.mojo:exec-maven-plugin

link publish delete flag offensive edit
0

answered 2020-07-20 16:17:58 +0800

MDuchemin gravatar image MDuchemin
1743 1 5
ZK Team

Hey andij62,

Sounds like something went wrong while building. Which step were you at / which command did you run when getting this error? do you get more info in here?

npm ERR! A complete log of this run can be found in: npm ERR! /Users/andrel-dev/.npm/logs/2020-07-17T144718693Z-debug.log

I've tested the guide step by step, and I don't see any compilation issues on my side. You might want to check the following steps:

A - install less, node, npm C - run the sh init.sh script (important, as it set up your project's variables) H - package from maven command (you can try running it with the -X argument for verbose mode)

link publish delete flag offensive edit
0

answered 2020-07-20 18:25:59 +0800

andij62 gravatar image andij62
307 1 7

Here are the infos from the log-file:

image description

link publish delete flag offensive edit

Comments

looks like you missed to execute npm install after cloning the repo when initializing the probject. besides I'd recommend using the latest npm version (at least of your major verison 10.x is 10.21.0)

cor3000 ( 2020-07-21 11:13:00 +0800 )edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
2 followers

RSS

Stats

Asked: 2020-07-15 21:58:34 +0800

Seen: 17 times

Last updated: Jul 21

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More