0

Date issue daylight

asked 2020-02-07 01:39:27 +0800

fabiana gravatar image fabiana
0

I'm using ZK 9 and seems that summer time (daylight) is active. When I read some date from database, ZK shows with difference of one day. Can I disable this function? The preferred timeZone is set to GMT-3 at zk.xml

delete flag offensive retag edit

2 Replies

Sort by ยป oldest newest

answered 2020-02-07 14:36:02 +0800

cor3000 gravatar image cor3000
5250 2 7
ZK Team

updated 2020-02-07 14:37:46 +0800

can you provide which component you are using causing this issue? Also what information are you reading from your DB? GMT-3 is an offset-timezone unaware of any daylight savings.

So your code might just do the correct thing and your preferred timeZone is incorrectly set to an offset timezone, and should instead be a named timezone in the form of "America/Halifax" or similar (you forgot to mention your country's timezone).

Hard coding the offset is most likely wrong, even if your country doesn't have DST now, it might have had DST in the past or switch in the future. Causing trouble at past or future dates you are reading from your DB.

link publish delete flag offensive edit

answered 2020-02-10 20:50:41 +0800

fabiana gravatar image fabiana
0

I've reconfigured the zk.xml removing the preferred timezone to use the default one. Now all the components are working well. Thank you for your help.

link publish delete flag offensive edit
Your reply
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
1 follower

RSS

Stats

Asked: 2020-02-07 01:39:27 +0800

Seen: 9 times

Last updated: Feb 10

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More