0

ZK 9 Embedded

asked 2020-01-23 01:25:01 +0800

afxgroup gravatar image afxgroup
126 2

Hello, i'm trying to embed an app into an html page and i'm doing the same thing i found here: https://blog.zkoss.org/2019/12/17/zk-9-highlight-embedding-your-zk-app-into-a-3rd-party-app/ except for the fact that i don't use NodeJs but a wordpress app.

I have working ZK app at address https://lotto.animasystems.com/Lotto/futurobet/index.zul (you can test it yourself)

I've added the embed code into zk.xml file

<library-property>
        <name>org.zkoss.web.servlet.http.embedded.enabled</name>
        <value>true</value>
</library-property>

But the javascript is not found here:

https://lotto.animasystems.com/Lotto/zkau/web/js/zkmax/embedded/embedded.js

and this is my tomcat output.

22-Jan-2020 18:05:43.335 INFO [main] org.zkoss.zk.ui.http.WebManager.<init> Starting ZK 9.0.0 EE (build: 2019121010)
22-Jan-2020 18:05:43.350 INFO [main] org.zkoss.zk.ui.sys.ConfigParser.parseConfigXml Loading system default
22-Jan-2020 18:05:43.435 INFO [main] org.zkoss.zk.ui.sys.ConfigParser.parse Parsing jar:file:/tomcat9/webapps/Lotto/WEB-INF/lib/zul-9.0.0.jar!/metainfo/zk/zk.xml
22-Jan-2020 18:05:43.444 INFO [main] org.zkoss.zk.ui.sys.ConfigParser.parse Parsing jar:file:/tomcat9/webapps/Lotto/WEB-INF/lib/zkex-9.0.0.jar!/metainfo/zk/zk.xml
22-Jan-2020 18:05:43.447 INFO [main] org.zkoss.zk.ui.sys.ConfigParser.parse Parsing jar:file:/tomcat9/webapps/Lotto/WEB-INF/lib/zkmax-9.0.0.jar!/metainfo/zk/zk.xml
22-Jan-2020 18:05:43.451 INFO [main] org.zkoss.zk.ui.sys.ConfigParser.parse Parsing file:/tomcat9/webapps/Lotto/WEB-INF/zk.xml

So everything should be ok. What is wrong with my installation?

delete flag offensive retag edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-02-04 11:04:33 +0800

cor3000 gravatar image cor3000
5099 2 7
ZK Team

when I try to access your script-url at ... https://lotto.animasystems.com/Lotto/zkau/web/js/zkmax/embedded/embedded.js ... I get a response. So this looks correct to me, maybe you fixed the problem in the mean time.

Do you get any cross origin errors (CORS) in your browser console, when trying to embed this into your wordpress page?

link publish delete flag offensive edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
1 follower

RSS

Stats

Asked: 2020-01-23 01:25:01 +0800

Seen: 9 times

Last updated: Feb 04

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More