0

Migrate to ZK 9 From ZK 8 gives error

asked 2020-01-09 01:06:11 +0800

Senthilchettyin gravatar image Senthilchettyin flag of India
2623 3 8
http://emrpms.blogspot.in...

updated 2020-01-09 10:34:21 +0800

cor3000 gravatar image cor3000
5069 2 7
ZK Team

Hello

The below line says it no longer exists in zk 9

setModel(new BindingListModelList(allReordsInDB, true));
delete flag offensive retag edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-01-09 10:43:08 +0800

MDuchemin gravatar image MDuchemin
1511 1 5
ZK Team

Hi Sentil,

This using this class is not recommended in the current ZK versions (it has been deprecated for a while). This said, the classes are still available in a legacy package, and you can still do a direct version upgrade without any change to your code by adding the zkplus-legacy dependency to your project.

    <dependency>
        <groupId>org.zkoss.zk</groupId>
        <artifactId>zkplus-legacy</artifactId>
        <version>${zk.version}</version>
    </dependency>
link publish delete flag offensive edit

Comments

Thank you. Can you please tell me the latest version way of doing the same ?

Senthilchettyin ( 2020-01-09 10:56:57 +0800 )edit

this jar exists since zk version 9.0.0 see ZK-4343

cor3000 ( 2020-01-09 11:28:40 +0800 )edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow

RSS

Stats

Asked: 2020-01-09 01:06:11 +0800

Seen: 14 times

Last updated: Jan 09

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More