0

zk.wpd 文件存在js漏洞

asked 2019-09-12 13:05:21 +0800

yuanmei gravatar image yuanmei
1

updated 2019-09-17 11:05:38 +0800

cor3000 gravatar image cor3000
4912 2 7
ZK Team

安全扫描时,提示zkau/web/dbd7a4be/js/zk.wpd存在js漏洞,要怎么解决?

delete flag offensive retag edit

Comments

Please provide more info: which tool was used for the testing? which error occurred? which ZK version was used?

jeanher ( 2019-09-12 16:15:52 +0800 )edit

ZK version is 5.0.9; Javascript vulnerability exists in zkau/web/dbd7a4be/js/zk.wpd ;

yuanmei ( 2019-09-17 09:38:58 +0800 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-09-17 11:03:16 +0800

cor3000 gravatar image cor3000
4912 2 7
ZK Team

Old versions naturally contain older code which can get outdated. Without upgrading to a newer version you won't receive any bug/browser fixes, security updates. 5.0.9 was released ~8 years ago and obviously doesn't contain any security updates since then. Did you try a more recent version?

And again, without sharing any information on which tool was used or which vulnerability was detected no one will be able to help you (especially not here in the forum).

Please consider contacting ZK for dedicated support if you don't want to disclose any vulnerabilities in a public forum.

https://www.zkoss.org/support/about/contact

link publish delete flag offensive edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
2 followers

RSS

Stats

Asked: 2019-09-12 13:05:21 +0800

Seen: 14 times

Last updated: Sep 17

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More