0

Combobox - lost input characters

asked 2019-09-11 21:58:28 +0800

zkulm gravatar image zkulm
100 1

updated 2019-09-11 22:04:09 +0800

Hi ZK community,

we have an issue using the combobox. By typing in slowly characters in the combox, sometimes characters are lost.

This is reproducible in the ZK sandbox environment with the default coding for the combobox.

By entering slowly e.g. "accu" (for matchin accuracy) characters are lost if they are entered (keystroke) during the rendering of the component. In my case, e.g. the "c" is getting lost. Unfortunately, i can't attach a gif showing the issue as i am a new user.

The bug is reproducible with the latest versions of Google Chrome and Mozilla Firefox.

Does someone have any idea how to solve the issue or is it already reported to the community?

Thanks for your help!

delete flag offensive retag edit

Comments

Welcome to the forum, I increased your karma so you can post links. Ideally to a runnable reproducing example on http://zkfiddle.org/

cor3000 ( 2019-09-12 11:53:18 +0800 )edit

4 Answers

Sort by ยป oldest newest most voted
1

answered 2019-09-18 18:29:24 +0800

cor3000 gravatar image cor3000
4887 2 7
ZK Team

updated 2019-09-20 12:33:04 +0800

Hi again,

here my first attempt to patch/workaround the issue.

http://zkfiddle.org/sample/27n8vht/3-Combobox-lost-input-characters-patch

If you can test this on your side I'll post an official bug with this workaround. I hope it doesn't cause unwanted side effects.

UPDATE: I posted the bug ticket ZK-4383

Robert

link publish delete flag offensive edit
0

answered 2019-09-12 13:53:01 +0800

zkulm gravatar image zkulm
100 1

Hi cor3000, thank you!

Please see here my simple example: http://zkfiddle.org/sample/27n8vht/1-Combobox-lost-input-characters

If you increase my karma to 100 then i will attach you a gif showing the issue.

Thanks!

link publish delete flag offensive edit

Comments

no need for a video, I can reproduce this issue easily

cor3000 ( 2019-09-12 16:14:39 +0800 )edit
0

answered 2019-09-12 16:39:46 +0800

zkulm gravatar image zkulm
100 1

Ok, thanks. Looking forward for help on this issue :)

link publish delete flag offensive edit

Comments

right now I don't have a workaround, it's overlapping ajax request/responses while typing, hard to avoid that. I can try next week since tomorrow is a public holiday here.

cor3000 ( 2019-09-12 19:09:33 +0800 )edit
0

answered 2019-09-19 20:24:13 +0800

zkulm gravatar image zkulm
100 1

Hi Robert, i integrated the script in our code and it seems to solve the issue. So far, no characters were lost anymore and i did not have any side effects yet.

I'll do some more test and once i notice something strange, i'll let you know.

But so far it seems to work :-) Thank you very much for this fast help, i appreciate that very much!

Regards Philipp

link publish delete flag offensive edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
2 followers

RSS

Stats

Asked: 2019-09-11 21:58:28 +0800

Seen: 24 times

Last updated: Sep 20

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More