0

Listbox multiple not work

asked 2019-05-31 14:50:49 +0800

turranor gravatar image turranor
101 1

Hi, In ZK 5.7.0.1 my listbox was normal with checkmarkand multiple but when i upgrade it to v8.6.0 checkmarks turn to radio button, multiple is not working. My code is:

<listbox id="myListBox" mold="paging" checkmark="true"
        pageSize="13" multiple="true" width="99%" height="480px">


... model = new ListModelList(list);
        tmp = (Listbox) window.getFellowIfAny("myListBox");
        tmp.setModel(model);
        tmp.setCheckmark(true);
        tmp.setMultiple(true);

How can i solve this? Thank you for your replies.

delete flag offensive retag edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-05-31 17:14:20 +0800

cor3000 gravatar image cor3000
4546 2 7
ZK Team

updated 2019-05-31 17:27:47 +0800

when using a listmodel you have to enable multiple selection on the listmodel

    model = new ListModelList(list);
    model.setMultiple(true);
    tmp = (Listbox) window.getFellowIfAny("myListBox");
    tmp.setModel(model);
    tmp.setCheckmark(true);

https://www.zkoss.org/wiki/ZK%20Component%20Reference/Data/Listbox#Enablewitha_ListModel

link publish delete flag offensive edit

Comments

thank you very much.

turranor ( 2019-05-31 19:11:31 +0800 )edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
1 follower

RSS

Stats

Asked: 2019-05-31 14:50:49 +0800

Seen: 7 times

Last updated: May 31

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More