Revision history [back]

click to hide/show revision 1
initial version

answered 2019-10-15 10:37:03 +0800

cor3000 gravatar image cor3000

ZK Team

You have to place the timeout configuration elements into a <session-config> element in. It looks like you accidentally used <device-config> (which should also fail in any other application server, like tomcat/jetty/wildfly/glassfish/...)

<session-config>
    <device-type>ajax</device-type>    
    <timeout-message>time out.</timeout-message>
    <timeout-uri>/timeout.zul</timeout-uri><!-- An empty URL can cause the browser to reload the same URL -->
    <automatic-timeout>true</automatic-timeout>
</session-config>

Related documentation:

In case you copy pasted your configuration snipped from somewhere in our documentation please provide the location so we can fix it.

You have to place the timeout configuration elements into a <session-config> element in. It looks like you accidentally used <device-config> (which should also fail in any other application server, like tomcat/jetty/wildfly/glassfish/...)

<session-config>
    <device-type>ajax</device-type>    
    <timeout-message>time out.</timeout-message>
    <timeout-uri>/timeout.zul</timeout-uri><!-- An empty URL can cause the browser to reload the same URL -->
    <automatic-timeout>true</automatic-timeout>
</session-config>

Related documentation:

In case you copy pasted your configuration snipped from somewhere in our documentation please provide the location so we can fix it.

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More