0

Update Zk from zk 6.5.4 to zk 6.5.8 or zk 8 (problem)

asked 2015-11-25 08:25:46 +0800

longdv1208 gravatar image longdv1208
98 4

updated 2015-11-27 02:09:11 +0800

I'm using 6.5.4 zk I then try to upgrade 6.5.8 and 8.0.0 zk. After the config upgraded and build, I start Tomcat 7 successfully Login app. click login button. Thank Sees images image description

I changed the following parameters in zk.xml. But it has no effect Change from 0 to 390

<client-config>
    <click-filter-delay>0</click-filter-delay>
</client-config>
    <client-config>
    <processing-prompt-delay>1</processing-prompt-delay>
</client-config>
delete flag offensive retag edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2015-11-27 06:51:55 +0800

chillworld gravatar image chillworld flag of Belgium
5322 4 9
https://github.com/chillw...

updated 2016-01-21 05:53:14 +0800

Looks like you need to declare the session-timeout in zk.xml

With this field you can control the time before your session timeouts.

Edit:

yesterday I had almost the same problem with timeouts.
Our config is a loadbalancer and 2 servers where the application is deployed.
The moment an onChange event was triggered, I get a session timeout.
Navigating the application or clicking a button was no problem.

This issue comes from a bad configuration on the server. In server logging I got :

Unable to invoke public static final java.lang.String org.zkoss.zk.ui.http.Wpds.outLocaleJavaScript(javax.servlet.ServletRequest,javax.servlet.ServletResponse) throws java.io.IOException

Chill.

link publish delete flag offensive edit
0

answered 2015-11-30 06:59:24 +0800

longdv1208 gravatar image longdv1208
98 4

updated 2015-11-30 07:00:11 +0800

I config zk.xml
Sometimes it has been.

<session-config>
    <session-timeout>0</session-timeout>
    <device-type>ajax</device-type>
    <timeout-message>Session timeout. Please reload.</timeout-message>
</session-config>
link publish delete flag offensive edit

Comments

Try changing that timeout to 120 to test. 0 means webservers default.

chillworld ( 2015-11-30 07:32:35 +0800 )edit

I try changing that time to 120. <session-timeout>120</session-timeout>. but Sometimes it has been.

longdv1208 ( 2015-12-02 06:50:28 +0800 )edit

so sometime you still have this? What does the stacktrace say? Can you find where it is triggered?

chillworld ( 2015-12-02 07:22:43 +0800 )edit

I try changing that timeout value 0,60,120 but problem. No stack trace

longdv1208 ( 2015-12-28 02:26:26 +0800 )edit

Can you recreate the issue in a small application so I can test that one?

chillworld ( 2016-01-13 06:25:15 +0800 )edit
0

answered 2016-01-21 07:52:09 +0800

Darksu gravatar image Darksu
1991 1 4

Hello,

Please find below the full example of the configuration for the session:

<session-config>
    <session-timeout>1800</session-timeout>
    <timer-keep-alive>false</timer-keep-alive>
    <max-desktops-per-session>15</max-desktops-per-session>
    <max-requests-per-session>5</max-requests-per-session>
    <max-pushes-per-session>3</max-pushes-per-session>
</session-config>

Best Regards,

Darksu

link publish delete flag offensive edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
1 follower

RSS

Stats

Asked: 2015-11-25 08:25:46 +0800

Seen: 59 times

Last updated: Jan 21 '16

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More