0

org.zkoss.zk.ui.util.Configuration afterComponentAttached

asked 2015-04-23 10:46:07 +0800

Amu gravatar image Amu
1

My code is showing output properly. But on console it shows like this--> java.lang.NoSuchMethodError: org.zkoss.zk.ui.Component.getAttribute(Ljava/lang/String;Z)Ljava/lang/Object; Please tell me why it shows??? And how to remove it??

delete flag offensive retag edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-05-10 16:57:33 +0800

Darksu gravatar image Darksu
1991 1 4

Hello Amu,

You project's configuration is missing libraries.

Please download again the latest zk version (check if your are using components that belong to PE or EE), or reconfigure your maven's library dependencies accordingly.

http://books.zkoss.org/wiki/ZKInstallationGuide/SettingupIDE/Maven/ResolvingZKFrameworkArtifactsvia_Maven

http://books.zkoss.org/wiki/ZKStudioEssentials/Installation

http://www.zkoss.org/download/zk

Best Regards,

Darksu

link publish delete flag offensive edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
1 follower

RSS

Stats

Asked: 2015-04-23 10:46:07 +0800

Seen: 14 times

Last updated: May 10 '15

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More