0

zkcomet mod_proxy timeout

asked 2015-03-03 19:05:01 +0800

ceth85 gravatar image ceth85
3 1

Dear community,

i've got a problem with a ZK application setup.

I proxy a tomcat instance on another server through an Apache with mod_proxy to port 80. The VirtualHost configuration looks like this:

    ProxyPreserveHost On
    ProxyPass /app http ://appserver.sourcedomain.de/app timeout=600 Keepalive=On
    ProxyPassReverse /app http ://appserver.sourcedomain.de:8008/app 

    ProxyPassReverseCookieDomain appserver.sourcedomain.de www.targetdomain.de

Everything works fine but zkcomet request times out with the following webserver log entry:

[Tue Mar 03 19:46:44.414582 2015] [proxy_http:error] [pid 21939] (70007)The timeout specified has expired: [client MYIPADDRESS:53240] AH01102: error reading status line from remote server appserver.sourcedomain.de:8008, referer: http ://www.targetdomain.de/app/index.zul
[Tue Mar 03 19:46:44.414629 2015] [proxy:error] [pid 21939] [client MYIPADDRESS:53240] AH00898: Error reading from remote server returned by /app/zkcomet, referer: http  ://www.targetdomain.de/app/index.zul

Has someone got a hint for me why this is happening? I tried everything, also with AJP connector but the result is the same.

Regards, ceth85

P.S. sorry for the spaces in the URLs but my karma... you know...

delete flag offensive retag edit

Comments

Thanks vincentjian for your response!

I'm using ZK 7.0.4. Which setting should i use for disabling the timeout? ProxyTimeout and the timeout attribute by ProxyPass throws this error after restart apache: ProxyPass Timeout must be at least one second

Cheers ceth85

ceth85 ( 2015-03-04 10:10:25 +0800 )edit

You can try adding "TimeOut -1" in your httpd.conf file directly.

vincentjian ( 2015-03-05 03:11:26 +0800 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-03-04 09:00:37 +0800

vincentjian gravatar image vincentjian
2245 6

updated 2015-03-06 04:01:50 +0800

There is a known issue for comet server push and apache timeout setting, check this tracker: http://tracker.zkoss.org/browse/ZK-2269.

If you are using ZK 6.5.x, please try upgrading to ZK 7.0.2 or later. Or you can turn off the timeout setting in apache by setting timeout value to -1.

link publish delete flag offensive edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
1 follower

RSS

Stats

Asked: 2015-03-03 19:05:01 +0800

Seen: 16 times

Last updated: Mar 06 '15

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More