1

borderlayout in include not display with height="100%"

asked 2014-09-19 00:10:58 +0800

andresmq gravatar image andresmq
12 3

hi,

I have the following code

contenido.zul

<window border="none" apply="org.zkoss.bind.BindComposer"
viewModel="@id('vmin') @init('org.demo.InstruccionDlg')" width="80%" height="100%">

 <borderlayout  height="100%">
 <center autoscroll="true" >
 <label value="hola">
</center>
</borderlayout>
</window>

principal.zul

<borderlayout apply="org.zkoss.bind.BindComposer" viewModel="@id('vm') @init('org.demo.Principal')">
<north>
    <include src="navbar.zul"/>      
</north>
<center>
<include src="contenido.zul"/> 
</center>
</borderlayout>

But contenido.zul not shown unless you step height = "400px", but not from height = "100%".

I have searched for information about it but no solution. Working with ZK 7.0.3 CE

Thanks for any suggestions.

delete flag offensive retag edit

Comments

thank you very much Greetz

andresmq ( 2014-09-19 16:52:16 +0800 )edit

4 Answers

Sort by » oldest newest most voted
0

answered 2014-09-19 02:27:15 +0800

chillworld gravatar image chillworld flag of Belgium
5322 4 9
https://github.com/chillw...

Hi,

Try vflex="1"

Greetz chill.

link publish delete flag offensive edit
0

answered 2015-04-04 13:01:05 +0800

Senthilchettyin gravatar image Senthilchettyin flag of India
2611 3 8
http://emrpms.blogspot.in...

Hello

I also have the same problem. here is the layout

<zk xmlns:n="native">
<window id="windowOuterMain" width="100%" height="100%"
    border="none" sclass="outerwin" ctrlKeys="#f12#f11#f10#f2#f9"
    onClientInfo="@command('updateClientInfo', width=event.desktopWidth, height=event.desktopHeight, orientation=event.orientation)"
    apply="org.zkoss.bind.BindComposer"
    viewModel="@id('vm') @init('com.product.webapp.main.MainVM')">
    <include src="navbar.zul" />
    <hlayout id="main" spacing="0">
        <include id="sidebar" src="sidebar.zul" />
        <vlayout spacing="0" hflex="1">
            <include src="breadcrumbs.zul" />
            <borderlayout id="mainlayout" height="100%">
                <center id="center" autoscroll="false"
                    border="none">
                    <div id="screeensdiv"></div>
                </center>

                <south border="none" size="6%">
                    <div align="center">
                        <image width="50px"
                            src="/images/medxlogo.png" />
                        <label
                            value="Copyright © 2012 MedX Group Inc All Rights Reserved"
                            sclass="screenheaderlabel" />
                    </div>
                </south>
            </borderlayout>



        </vlayout>
    </hlayout>
</window>

</zk>

It works only when i put height in pixels for borderlayout. It never works for 100%

link publish delete flag offensive edit
0

answered 2015-04-06 14:20:18 +0800

Darksu gravatar image Darksu
1991 1 4

Hello Senthilchettyin,

Could you please post the included zul pages in order to investigate it in more detail?

Best Regards,

Darksu

link publish delete flag offensive edit
0

answered 2015-05-26 16:20:57 +0800

eclipse1 gravatar image eclipse1
21 4

Hello

I also have the same problem with the height of the borderlayout.

Here is the page that calls the include.

<zk>
  <window border="normal" apply="pkg$.TestComposer" width="100%" height="100%">
     <label value="You are seeing index.zul content." />
     <include src="borderlayout.zul"/>
  </window>
</zk>

Here is the borderlayout.zul

<window border="none" apply="org.zkoss.bind.BindComposer" width="100%" height="100%">

 <borderlayout vflex="1" hflex="1">
    <center autoscroll="true">
          <div>
            <label value="You are seeing borderlayout.zul content." />
          </div>
    </center>
 </borderlayout>
</window>

When i inspected the element, the height of the bordelayout was 0px. It doesn't work having neither with vflex="1" or height="100%" on the borderlayout.

link publish delete flag offensive edit

Comments

Please make a new question in stead of polluting older questions. You can refer to this question in your new question.

chillworld ( 2015-05-26 17:49:31 +0800 )edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
1 follower

RSS

Stats

Asked: 2014-09-19 00:10:58 +0800

Seen: 70 times

Last updated: May 26 '15

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More